summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-09 19:31:19 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-09 19:48:45 +0100
commit820a288c5d4bd2326f1145f5d2b6854428c8736c (patch)
tree50013ecf7436f20af3a28947ead9312d568118c7
parentdev-python/joblib: Bump to 1.0.1 (diff)
downloadgentoo-820a288c.tar.gz
gentoo-820a288c.tar.bz2
gentoo-820a288c.zip
dev-python/mpmath: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mpmath/Manifest1
-rw-r--r--dev-python/mpmath/mpmath-1.2.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
index 021ebeb7abfe..5a871d21a765 100644
--- a/dev-python/mpmath/Manifest
+++ b/dev-python/mpmath/Manifest
@@ -1 +1,2 @@
DIST mpmath-1.1.0.tar.gz 2136921 BLAKE2B 8c3a5f39b48015aab1147aaf77ee7523dbffd7f34911ff2158d7b8bf1612e64f91d157494c5199b22090e986aba02044d610171bb92a2b230cdfbe025652e340 SHA512 628b6c61015825516d983bfcc54fc3a2793f3d9d2b93ba9c5a487a340ddf13eb4e83f17fa35692b22dd8a200a8da3a65ed88091d75abb4c48c9c4e4f2c686bcc
+DIST mpmath-1.2.1.tar.gz 2135690 BLAKE2B a21e0ef04a025f23e32dad5839db411708266c6cf3408e97ec5c995f197b14f446c1d328bd2e9f50e1c48a2e08239ef7908fcc3aab8659118fc1e0e78106a47e SHA512 2dd908bca26162adcdce0493146d009e04d3d96db965ff2207c332504020fa6f5a5e2af97d38e8fb3e7442a26c1e93a756a8d93b378da720ab7c07753f700d10
diff --git a/dev-python/mpmath/mpmath-1.2.1.ebuild b/dev-python/mpmath/mpmath-1.2.1.ebuild
new file mode 100644
index 000000000000..ee062f0cf511
--- /dev/null
+++ b/dev-python/mpmath/mpmath-1.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="https://mpmath.org/"
+SRC_URI="https://github.com/fredrik-johansson/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="gmp matplotlib test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ gmp? ( dev-python/gmpy[${PYTHON_USEDEP}] )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ pushd ${PN}/tests >/dev/null
+ ${EPYTHON} runtests.py -local || die "Tests failed with ${EPYTHON}"
+ popd >/dev/null
+}