summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-15 18:47:37 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-16 06:23:13 +0200
commit821c9de23a38f53edd930d3ab9613b0b763b7569 (patch)
tree27024b9b2a24bebd130549b5e313e7fd2eb2c7a8
parentdev-ruby/maildir: enable ruby32 (diff)
downloadgentoo-821c9de2.tar.gz
gentoo-821c9de2.tar.bz2
gentoo-821c9de2.zip
app-text/webgen: fix minitest deprecation
Closes: https://bugs.gentoo.org/911743 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--app-text/webgen/webgen-1.7.2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-text/webgen/webgen-1.7.2.ebuild b/app-text/webgen/webgen-1.7.2.ebuild
index 50a71eab42a2..f6e1b0bec434 100644
--- a/app-text/webgen/webgen-1.7.2.ebuild
+++ b/app-text/webgen/webgen-1.7.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+USE_RUBY="ruby30 ruby31 ruby32"
RUBY_FAKEGEM_RECIPE_DOC="task"
RUBY_FAKEGEM_DOCDIR="htmldoc/rdoc"
@@ -46,6 +46,9 @@ all_ruby_prepare() {
# Avoid tests failing with newer Psych versions
rm -f test/test_documentation.rb || die
+
+ # Fix minitest deprecation
+ sed -i -e 's/MiniTest/Minitest/' $(find test -type f -print) || die
}
all_ruby_install() {