summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-19 15:51:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-19 16:03:13 +0200
commit821f6672184da7b5de377ff888842e8708136af6 (patch)
tree18e371a26c641239428676aa807123f6eb8ad7e0
parentdev-ml/async: remove old. (diff)
downloadgentoo-821f6672184da7b5de377ff888842e8708136af6.tar.gz
gentoo-821f6672184da7b5de377ff888842e8708136af6.tar.bz2
gentoo-821f6672184da7b5de377ff888842e8708136af6.zip
dev-ml/async: bump to 113.00.00
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-ml/async/Manifest1
-rw-r--r--dev-ml/async/async-113.00.00.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/async/Manifest b/dev-ml/async/Manifest
index a66804de081f..a6a32d97ce4b 100644
--- a/dev-ml/async/Manifest
+++ b/dev-ml/async/Manifest
@@ -1 +1,2 @@
DIST async-112.35.00.tar.gz 88263 SHA256 95228894bba807f1c3537530b8008d9c91a58708936d1f5c2101561b16125d85 SHA512 585585eee879d5f2f67ca2dbac520bc417deed2f867a870fa8d2d05da943b269f440983f983353f45c408998c8b5535c5a3b81ed0035d673bd656c416f96bf0b WHIRLPOOL 9dc8f92f65431b25fc7e322be2be4cb85473b55ec4ca8e2b5ee5f7b1dd0d4e6050cc78fe8017ff351b5bfb849f3d686e9fdd4c277ffe9c2adfbc90972fdf9aab
+DIST async-113.00.00.tar.gz 90226 SHA256 c8ada3aebff8faf0dce069043cca2bcd3c73b71024348c6d4082742c35bb3c90 SHA512 915752898c3ab14c89e01a89d77c5845a4774347b5efa54e62125cea95a8b59873c5f03833d63b6677d31c19609b676ce056ed126a0f747234dde166350a3456 WHIRLPOOL 482fe4b73379829be1b0662322f691a082dd5b83f78da717e7c62f12d080aaf6c34d7f0997ab97b701627280620dcc0ae6698871ea949c7d6ca48bb0a81b5f1f
diff --git a/dev-ml/async/async-113.00.00.ebuild b/dev-ml/async/async-113.00.00.ebuild
new file mode 100644
index 000000000000..8598a7657320
--- /dev/null
+++ b/dev-ml/async/async-113.00.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ >=dev-ml/async_extra-${PV}:=
+ dev-ml/camlp4:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 dev-ml/core_bench dev-ml/pa_ounit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}