summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-21 20:22:12 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-21 20:27:51 +0100
commit822044c33a753789350a887498a4186d56e16721 (patch)
tree352aa4b6fbde30f3f71ede26dcc0dc3eff81d3b2
parentdev-python/lxc-python2: Remove last-rited package (diff)
downloadgentoo-822044c33a753789350a887498a4186d56e16721.tar.gz
gentoo-822044c33a753789350a887498a4186d56e16721.tar.bz2
gentoo-822044c33a753789350a887498a4186d56e16721.zip
dev-python/mantissa: Remove last-rited package
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mantissa/Manifest2
-rw-r--r--dev-python/mantissa/mantissa-0.7.0-r1.ebuild45
-rw-r--r--dev-python/mantissa/mantissa-0.8.4.ebuild48
-rw-r--r--dev-python/mantissa/metadata.xml15
-rw-r--r--profiles/package.mask1
5 files changed, 0 insertions, 111 deletions
diff --git a/dev-python/mantissa/Manifest b/dev-python/mantissa/Manifest
deleted file mode 100644
index a193f5f987d7..000000000000
--- a/dev-python/mantissa/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST Mantissa-0.7.0.tar.gz 827087 BLAKE2B e7201518a87237ba48778692e7665300bf032f06fee175df16cc47bfddeaac62591dbf88247da163e4dd14d1b4fb948450ff09424922ce6ae884527acc950bfc SHA512 a0ef58902d0d752f2643f0c9639d9338a0441651cc0a2c3b45493a79b81757c4b642a7adcc940e0228033280927b7dad460a345fac62da1dcb9d73babd981d8c
-DIST mantissa-0.8.4.tar.gz 832649 BLAKE2B 1658f34d9f3328953628da188849c7b9b522ece03898398ff7181aa1122c82c9aa2f9e4ac862553177fe559d653aa63a7eea0b067ced594215546635f053a839 SHA512 448f26cb540e7d19ede1b39c1b0157ccdd04baeac6cb8eb918fec2eb2bd395e12b0a659633ffb4c260a84c87025b81b41a8e168e7d1f1a0235bfe25f492c2c32
diff --git a/dev-python/mantissa/mantissa-0.7.0-r1.ebuild b/dev-python/mantissa/mantissa-0.7.0-r1.ebuild
deleted file mode 100644
index d1779b496aa2..000000000000
--- a/dev-python/mantissa/mantissa-0.7.0-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit twisted-r1
-
-DESCRIPTION="An extensible, multi-protocol, multi-user, interactive application server"
-HOMEPAGE="https://github.com/twisted/mantissa https://pypi.org/project/Mantissa/"
-SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
-
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND=">=dev-python/axiom-0.6.0-r1[${PYTHON_USEDEP}]
- >=dev-python/cssutils-0.9.10-r1[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- >=dev-python/nevow-0.10.0-r1[${PYTHON_USEDEP}]
- >=dev-python/pytz-2012j[${PYTHON_USEDEP}]
- dev-python/twisted-core[${PYTHON_USEDEP}]
- dev-python/twisted-mail[${PYTHON_USEDEP}]
- >=dev-python/vertex-0.3.0-r1[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-TWISTED_PLUGINS=( axiom.plugins nevow.plugins xmantissa.plugins )
-
-python_install() {
- distutils-r1_python_install
-
- # remove foreign caches we don't want to own
- find "${D}$(python_get_sitedir)" -name 'dropin.cache' -delete || die
- # then our own one
- touch "${D}$(python_get_sitedir)"/xmantissa/plugins/dropin.cache || die
-}
-
-python_install_all() {
- dodoc NAME.txt NEWS.txt
-
- distutils-r1_python_install_all
-}
-
-python_test() {
- trial xmantissa || die "tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/mantissa/mantissa-0.8.4.ebuild b/dev-python/mantissa/mantissa-0.8.4.ebuild
deleted file mode 100644
index 8b3fd5385d0b..000000000000
--- a/dev-python/mantissa/mantissa-0.8.4.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit twisted-r1
-
-MY_PN="${PN/m/M}"
-DESCRIPTION="An extensible, multi-protocol, multi-user, interactive application server"
-HOMEPAGE="https://github.com/twisted/mantissa https://pypi.org/project/Mantissa/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
- >=dev-python/axiom-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/cssutils-0.9.5[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- >=dev-python/nevow-0.9.5[${PYTHON_USEDEP}]
- >=dev-python/pytz-2012j[${PYTHON_USEDEP}]
- >=dev-python/twisted-core-14.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-mail-14.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-conch-14.0.0[${PYTHON_USEDEP}]
- >=dev-python/vertex-0.2[${PYTHON_USEDEP}]
- dev-python/pycrypto[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-TWISTED_PLUGINS=( axiom.plugins nevow.plugins xmantissa.plugins )
-
-python_test() {
- # https://github.com/twisted/mantissa/issues/27
-
- trial xmantissa || die "tests failed with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
-
- # remove foreign caches we don't want to own
- find "${D}$(python_get_sitedir)" -name 'dropin.cache' -delete || die
- # then our own one
- touch "${D}$(python_get_sitedir)"/xmantissa/plugins/dropin.cache || die
-}
diff --git a/dev-python/mantissa/metadata.xml b/dev-python/mantissa/metadata.xml
deleted file mode 100644
index be380a8e5f32..000000000000
--- a/dev-python/mantissa/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">Mantissa is an application server. It provides integration between
- the AxiomProject object database, and the TwistedFramework, as well
- as web user-interface utilities.</longdescription>
- <upstream>
- <remote-id type="pypi">Mantissa</remote-id>
- <remote-id type="github">twisted/mantissa</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 30be19d86433..c44bce64400f 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -633,7 +633,6 @@ net-im/silc-toolkit
# The following Gentoo packages are Python 2-only and have no reverse
# dependencies.
# Removal in 30 days. Bug #705762.
-dev-python/mantissa
dev-python/mkpythonproj
dev-python/morbid
dev-python/myghty