summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-03-01 13:45:22 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-03-01 15:41:28 +0200
commit823dd28ad208023866db3665228056ac37dba5fc (patch)
treeb004f4352589f224256f779686507a2c54728e31
parentdev-embedded/mspdebug: update EAPI 6 -> 8 (diff)
downloadgentoo-823dd28a.tar.gz
gentoo-823dd28a.tar.bz2
gentoo-823dd28a.zip
dev-embedded/mspdebug: drop 0.25
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--dev-embedded/mspdebug/mspdebug-0.25.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-embedded/mspdebug/mspdebug-0.25.ebuild b/dev-embedded/mspdebug/mspdebug-0.25.ebuild
deleted file mode 100644
index a4ff1ba9081b..000000000000
--- a/dev-embedded/mspdebug/mspdebug-0.25.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="A free debugger for use with MSP430 MCUs"
-HOMEPAGE="https://dlbeer.co.nz/mspdebug/ https://github.com/dlbeer/mspdebug"
-SRC_URI="https://github.com/dlbeer/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="readline"
-
-DEPEND="readline? ( sys-libs/readline:0= )
- virtual/libusb:0"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- sed -i "s:-O1 \(.*\) -ggdb:\1:" Makefile || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" LIBDIR=/usr/lib $(usex readline "" "WITHOUT_READLINE=1")
-}
-
-src_install() {
- emake DESTDIR="${ED}" LIBDIR=/usr/lib PREFIX=/usr install
- dodoc AUTHORS ChangeLog README
-}