summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-13 03:22:46 +0000
committerSam James <sam@gentoo.org>2023-11-13 03:22:46 +0000
commit823dd648849dc414f86db0639ea048697d8ace86 (patch)
treed90d8f3a6049fa38f7d4131deea6ab7330b416a5
parentsci-libs/openblas: add 0.3.25 (diff)
downloadgentoo-823dd648.tar.gz
gentoo-823dd648.tar.bz2
gentoo-823dd648.zip
app-shells/fzf: add 0.44.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-shells/fzf/Manifest2
-rw-r--r--app-shells/fzf/fzf-0.44.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index 392364a86cd9..1624cae2838f 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -2,3 +2,5 @@ DIST fzf-0.42.0-deps.tar.xz 16860372 BLAKE2B e2ba9a7deca036587e0f4ff40eabb849f83
DIST fzf-0.42.0.tar.gz 239469 BLAKE2B cdeb40d08345edaecc20082e5c9d487791260ae18dc824e585f522fdcb004dc645a9a59f8d26c01ffaaffffcee6ea9b7030b5e3a79d22098b3fad55e7ff2f9e7 SHA512 9587b8c9d37abcf1ae85b12d5cf3a1179f57241e3932db6801dee9bb952f83621b780d713c1793ccb4c5c36921b9078e156fe989b3e13664201ed729ea03d414
DIST fzf-0.43.0-deps.tar.xz 16866976 BLAKE2B 98d0412e7035f244d14c33e76a11d788a302239e09b8172a80ceb4e4bd253fcb57d131d2e2b5fc1bbecac13c9f967923f540220e31ca5741ed85f624da05d4cb SHA512 e0e7504d9bf8e932bb27a0e52df98cd542e1c690f711958981e041926141ff5570dbad14824036e8bb2e4a07a385eefed6ee005beb101efcfa45af89ce7acbef
DIST fzf-0.43.0.tar.gz 247080 BLAKE2B 63a0c446e93c753c7699e0575dfa0090d4f74d06e57e7d1c94f244638c21afd268c9da1b6a4b5dc85faa68e227f3c2c6755fa7af562d7f1ca5eec60e6e9141c1 SHA512 84e01d2f852e0d90b2a30342f7ad9a30e4e287688f6063efc2a0f602eab5ec064819efecd2041f46869bb1956b3d3eb50e98084deeaa26272c3bbafd000648f7
+DIST fzf-0.44.0-deps.tar.xz 16844060 BLAKE2B 33f85423868719cf86664a0fd7691c42c6ed94d0c5f83f9a296b430335cf142dd6d1f48b516bb9eceba98ca9e5ead9a99794279dcb79798c91e34db694b22c76 SHA512 e1824added348c7aa851c438384ebf2d585d44e634474144e5f444a41562b361574ecccff54c07ca046941ced8adec0596e52d540fe7d7ac786c85eccf683bfd
+DIST fzf-0.44.0.tar.gz 250927 BLAKE2B 3689d8843a4b008abc7b77e7b0fe7b681891c5f397ac7460c26ea303e04e7bb7dcb03af4012cfea12dd8c771c012a656e8bc65684941d66ebbb6533796d09ec2 SHA512 62084284a2329250e87f107900ffaddf94043274b1d9ede1dacdeed2e8ef87722c80708addd7907c35035e742645f5168776e5f0295d5695e9512acdbb43936c
diff --git a/app-shells/fzf/fzf-0.44.0.ebuild b/app-shells/fzf/fzf-0.44.0.ebuild
new file mode 100644
index 000000000000..12bc25a2e10a
--- /dev/null
+++ b/app-shells/fzf/fzf-0.44.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=7320b7df62039c879c4f609bca946ea09b438a98
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug #795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}