summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:17:15 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:34 +0100
commit826dda66b3e469e5c63f1660b5b3fc3dfbd71aa5 (patch)
treec401171ff9d7affd36706f6b7292c52787d20b0a
parentdev-lua/lanes: update EAPI 7 -> 8 (diff)
downloadgentoo-826dda66b3e469e5c63f1660b5b3fc3dfbd71aa5.tar.gz
gentoo-826dda66b3e469e5c63f1660b5b3fc3dfbd71aa5.tar.bz2
gentoo-826dda66b3e469e5c63f1660b5b3fc3dfbd71aa5.zip
dev-lua/lanes: drop 3.15.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/lanes/lanes-3.15.1.ebuild93
1 files changed, 0 insertions, 93 deletions
diff --git a/dev-lua/lanes/lanes-3.15.1.ebuild b/dev-lua/lanes/lanes-3.15.1.ebuild
deleted file mode 100644
index 5b0acc4cce82..000000000000
--- a/dev-lua/lanes/lanes-3.15.1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Lightweight, native, lazy evaluating multithreading library"
-HOMEPAGE="https://github.com/LuaLanes/lanes"
-SRC_URI="https://github.com/LuaLanes/lanes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-# Tests are currently somehow problematic.
-# https://github.com/LuaLanes/lanes/issues/197
-# https://github.com/LuaLanes/lanes/issues/198
-RESTRICT="test"
-
-RDEPEND="${LUA_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? ( ${RDEPEND} )
-"
-
-HTML_DOCS=( "docs/." )
-
-PATCHES=( "${FILESDIR}/${PN}-3.13.0-makefile.patch" )
-
-src_prepare() {
- default
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LUA=${ELUA}"
- "LUA_FLAGS=$(lua_get_CFLAGS)"
- "LUA_LIBS="
- "OPT_FLAGS=${CFLAGS}"
- )
-
- tc-export PKG_CONFIG
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- pushd "${BUILD_DIR}" || die
-
- emake LUA="${ELUA}" test
-
- popd
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "LUA_LIBDIR=${ED}/$(lua_get_cmod_dir)"
- "LUA_SHAREDIR=${ED}/$(lua_get_lmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}