summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-05-01 20:58:42 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-01 21:03:49 +0200
commit82750a31b643c6c6c26c5262b418f3b6e33e46dd (patch)
tree7b7aef9ff0e733b4849ef665be84db664c248556
parentapp-arch/lzlib: ppc64 stable wrt bug #825466 (diff)
downloadgentoo-82750a31.tar.gz
gentoo-82750a31.tar.bz2
gentoo-82750a31.zip
dev-util/bazel: fix JDK/JRE dependencies
The bazel versions in ::gentoo do not build with JDK 17. Restrict to suitable JDKs. Also make RDEPEND a JRE dependency. Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-util/bazel/bazel-3.7.2-r1.ebuild10
-rw-r--r--dev-util/bazel/bazel-4.2.2.ebuild8
-rw-r--r--dev-util/bazel/bazel-5.0.0.ebuild5
3 files changed, 16 insertions, 7 deletions
diff --git a/dev-util/bazel/bazel-3.7.2-r1.ebuild b/dev-util/bazel/bazel-3.7.2-r1.ebuild
index db3f1fbbb8c0..1ab7cb5b1b1b 100644
--- a/dev-util/bazel/bazel-3.7.2-r1.ebuild
+++ b/dev-util/bazel/bazel-3.7.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,8 +17,12 @@ IUSE="examples tools"
# strip corrupts the bazel binary
# test fails with network-sandbox: An error occurred during the fetch of repository 'io_bazel_skydoc' (bug 690794)
RESTRICT="strip test"
-RDEPEND=">=virtual/jdk-1.8:*"
-DEPEND="${RDEPEND}
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND="
+ || (
+ virtual/jdk:1.8
+ virtual/jdk:11
+ )
app-arch/unzip
app-arch/zip"
diff --git a/dev-util/bazel/bazel-4.2.2.ebuild b/dev-util/bazel/bazel-4.2.2.ebuild
index a8b93d4ab322..fb8928767133 100644
--- a/dev-util/bazel/bazel-4.2.2.ebuild
+++ b/dev-util/bazel/bazel-4.2.2.ebuild
@@ -17,8 +17,12 @@ IUSE="examples tools"
# strip corrupts the bazel binary
# test fails with network-sandbox: An error occurred during the fetch of repository 'io_bazel_skydoc' (bug 690794)
RESTRICT="strip test"
-RDEPEND=">=virtual/jdk-1.8:*"
-DEPEND="${RDEPEND}
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND="
+ || (
+ virtual/jdk:1.8
+ virtual/jdk:11
+ )
app-arch/unzip
app-arch/zip"
diff --git a/dev-util/bazel/bazel-5.0.0.ebuild b/dev-util/bazel/bazel-5.0.0.ebuild
index 778608f34249..36ee3e954ac0 100644
--- a/dev-util/bazel/bazel-5.0.0.ebuild
+++ b/dev-util/bazel/bazel-5.0.0.ebuild
@@ -17,8 +17,9 @@ IUSE="examples tools"
# strip corrupts the bazel binary
# test fails with network-sandbox: An error occurred during the fetch of repository 'io_bazel_skydoc' (bug 690794)
RESTRICT="strip test"
-RDEPEND=">=virtual/jdk-11:*"
-DEPEND="${RDEPEND}
+RDEPEND=">=virtual/jre-11:*"
+DEPEND="
+ virtual/jdk:11
app-arch/unzip
app-arch/zip"