summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-15 20:14:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-15 21:15:26 +0200
commit829b7f1d77943a92b221b256df2758c284b51fc8 (patch)
treeb2bfa487e964dc50131d32b792b04fbd1234680c
parentdev-python/dj-database-url: Bump to 2.1.0 (diff)
downloadgentoo-829b7f1d77943a92b221b256df2758c284b51fc8.tar.gz
gentoo-829b7f1d77943a92b221b256df2758c284b51fc8.tar.bz2
gentoo-829b7f1d77943a92b221b256df2758c284b51fc8.zip
dev-python/argon2-cffi: Bump to 23.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/argon2-cffi/Manifest1
-rw-r--r--dev-python/argon2-cffi/argon2-cffi-23.1.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/argon2-cffi/Manifest b/dev-python/argon2-cffi/Manifest
index 5e8fa5dedfce..e7373bba84e8 100644
--- a/dev-python/argon2-cffi/Manifest
+++ b/dev-python/argon2-cffi/Manifest
@@ -1 +1,2 @@
DIST argon2-cffi-21.3.0.tar.gz 38446 BLAKE2B e0464f501efcdfbf33d93e0c1c6dbc519ad6aee06c0b8692417156de608f6c6acf947f86b866c064601fe994087677e51d954ae2c1225cbbbba3534cf70c6296 SHA512 6cb2a075f3bb7040ee7f552d082bfa2f3df0854649d9c84fdfdb42bb4bee2133b8a35a20be2b3c887931efda12fbbb00815d8d88170b7e20b3ca19c86f97057e
+DIST argon2_cffi-23.1.0.tar.gz 42798 BLAKE2B 16f20c064bfc420894bc9da681ce4f544219c8e173f63bf095ffffdca6bd159695ecfa7ff33c32ca96f284764561e844e58d1ec3bf85a0c120c3b54490c3a56f SHA512 7c7730451f5ef9bb40bb5e1bbfa6e69c9718968168f3fa9b54e1020a4f805f98fba6260039bda804241717db2338479d640c7652dc26ce1a6ade076660133383
diff --git a/dev-python/argon2-cffi/argon2-cffi-23.1.0.ebuild b/dev-python/argon2-cffi/argon2-cffi-23.1.0.ebuild
new file mode 100644
index 000000000000..0767a88987da
--- /dev/null
+++ b/dev-python/argon2-cffi/argon2-cffi-23.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CFFI bindings to the Argon2 password hashing library"
+HOMEPAGE="
+ https://github.com/hynek/argon2-cffi/
+ https://pypi.org/project/argon2-cffi/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/argon2-cffi-bindings-21.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest