summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-27 04:50:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-27 05:54:40 +0200
commit82b364736436291f0aa58393dbb9f23c59e90e17 (patch)
treec42adfecddcc09386cb131b9de28094200686b54
parentdev-python/pip-run: Bump to 12.1.0 (diff)
downloadgentoo-82b364736436291f0aa58393dbb9f23c59e90e17.tar.gz
gentoo-82b364736436291f0aa58393dbb9f23c59e90e17.tar.bz2
gentoo-82b364736436291f0aa58393dbb9f23c59e90e17.zip
dev-python/sphinx-autodoc-typehints: Bump to 1.23.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 8ebc993a6e27..bc6b7d68da1e 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -2,3 +2,4 @@ DIST sphinx-autodoc-typehints-1.22.gh.tar.gz 35429 BLAKE2B d871de3d3a37b2632e6b4
DIST sphinx_autodoc_typehints-1.23.0.tar.gz 35945 BLAKE2B 4af9ddd722a1fc59d52009ef46ad7af828d826cce61e0bce260b68045d4abe3b184ffc0368b29f60eba210def8d8b3b37a5455442c156b326d4b9956c6afc32c SHA512 990db1f042913088fddf56cbc9ad5f401f7d886164c348aaf19fd1541fa1566a2d58d1c182e52d839d1dd32606ca3da1191b7062a6ed9c8f04dc6a47efaf5488
DIST sphinx_autodoc_typehints-1.23.1.tar.gz 36243 BLAKE2B e53dc42a31e358ca1e3fbbe41a3002abd4e1f470ed259d5b0b6f8def81de91653d1cb609e44dc10409340775ca877ea394e4fba1a5f2c3a38c10ce33996e12c8 SHA512 fe10d0ae4d23a979125868fd6743b37d2f65e1297620142c13cb59b83ba242e4b45098cc580c18232be1b535f5927ba6dd401f7cd4d3a39c2aab3611a2a751ed
DIST sphinx_autodoc_typehints-1.23.2.tar.gz 36198 BLAKE2B 15c47e89e50a1a88878f2ec5c511900ad5f0437975c041c99a33f2cc9e29de955b897bd6f853b010c0f8185cd669be9e8de351ee654e9bd640337a5771caeb62 SHA512 27e9a4179f050444dfbd3d4648212f1d56c47a938f8e33dded9121c5cd4637b4e2096eb383bbf663078223dc46973f3e0fcd02ecd162611d353ef5d702977f48
+DIST sphinx_autodoc_typehints-1.23.3.tar.gz 36290 BLAKE2B 11469aba26e8f146debe9e383d330c14bcbdde5c053fad45b189ae553a622d3ba25ac9ebc855c8dcfa7ab9ec8570db4e9fca3ecb6cab8f8396ee5ddb319d6db1 SHA512 013736d566d80027d40c381065125d429026788613c3dfd43311e8a33031c3a2f6161a0366b675259b4fac3c401658a9235c9f1c19abc2a220f27f0bead50b3f
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.3.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.3.ebuild
new file mode 100644
index 000000000000..c12ff85ed759
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.5[${PYTHON_USEDEP}]
+ >=dev-python/sphobjinv-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)