summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2024-04-08 21:02:09 +0000
committerMatthew Smith <matthew@gentoo.org>2024-04-08 21:02:09 +0000
commit82c3b73b10fe5a31955fb71bd95c08d9f2ec7ad4 (patch)
treebe64e02cbebb7f5d6bd981f97f76099fcf310888
parentdev-python/snakeoil: add 0.10.8 (diff)
downloadgentoo-82c3b73b10fe5a31955fb71bd95c08d9f2ec7ad4.tar.gz
gentoo-82c3b73b10fe5a31955fb71bd95c08d9f2ec7ad4.tar.bz2
gentoo-82c3b73b10fe5a31955fb71bd95c08d9f2ec7ad4.zip
net-mail/mu: add 1.12.3
Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.12.3.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index 18f51ec600ac..4ba2bebc40bd 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1,2 +1,3 @@
DIST mu-1.10.8.tar.xz 570792 BLAKE2B 6e65e77544011d0f6b8fb1a5ac4dfe074fe6af3504e2ce2577185a280af43c8d40e7ec3ed6bde90c6b6c6b4cd678a6ae5bae9430f7c2a03451f3f08fffe1c963 SHA512 d77fe955c44c09272feb7cd903dfc6f2a3b5974b81fef82bdb553ed2079e68451bb1ed11ce338ee2dfe9be835f0d99cb4ce0c4b41f43ecfad76e978732243c71
DIST mu-1.12.2.tar.xz 708852 BLAKE2B 72b9a0f8acad114d37a6dc7c214df5c6b2f3691f0f35dfe8408b3420e6d06d7e6345cd3db7bc32047c970367ac9d0374551fbbdff3616bcf9c96ebb7f9efcec5 SHA512 8733bdc6bed6e76278f052db8f270178f4ac269d610cd6f2ad44577be9b6fc8daeb85cd650b7ef2a21d141262065ecacdc9177fabd4bbe971d917943a2669b07
+DIST mu-1.12.3.tar.xz 714488 BLAKE2B 2f5ded323d94a028c33c447e877ec3cea3677bf69076893dd6751f69c47764eee2d779c13e8b5c601d0bd04beca4b8cef705a7fd2587fe1f81d22c381debee7a SHA512 27998f65636b42f7933cc39878d8900552aa1c94c90ea54f81d789c01eec5ddfdb93eb508b78a6416497c7c109193e1457b1ff2bafe98aa82ec88a4b5fc03832
diff --git a/net-mail/mu/mu-1.12.3.ebuild b/net-mail/mu/mu-1.12.3.ebuild
new file mode 100644
index 000000000000..7f369aaa2f8a
--- /dev/null
+++ b/net-mail/mu/mu-1.12.3.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common meson
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/releases/download/v${PV}/${P}.tar.xz"
+
+# mu: GPL-3+
+# + cli11: BSD
+# + fmt: MIT
+# + tl: CC0-1.0
+# + variant-lite: Boost-1.0
+LICENSE="BSD Boost-1.0 CC0-1.0 GPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~x64-macos"
+IUSE="emacs readline"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gmime:3.0
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-25.3:* )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-apps/texinfo
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://bugs.gentoo.org/925503
+ "${FILESDIR}"/${PN}-1.12.0-no-python.patch
+)
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_prepare() {
+ default
+
+ # Don't install NEWS.org into /usr/share/doc.
+ sed -i '/NEWS.org/,+1 d' meson.build || die
+ sed -i '/mu4e-about.org/d' mu4e/meson.build || die
+
+ # Don't compress the info file.
+ sed -i '/gzip/d' build-aux/meson-install-info.sh || die
+
+ # Instead, put it in /usr/share/doc/${PF}.
+ sed -i "/MU_DOC_DIR/s/mu/${PF}/" mu4e/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature readline)
+ -Dcld2=disabled
+ -Demacs="$(usex emacs "${EMACS}" emacs-not-enabled)"
+ # TODO: revisit this, it's not actually deprecated, just been reworked
+ -Dguile=disabled
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Since meson no longer installs NEWS.org, install it with dodoc.
+ # Also, it must be uncompressed so that it can be viewed with
+ # mu4e-info.
+ docompress -x /usr/share/doc/${PF}/NEWS.org
+ dodoc NEWS.org
+
+ if use emacs; then
+ # Same as above.
+ docompress -x /usr/share/doc/${PF}/mu4e-about.org
+ dodoc mu4e/mu4e-about.org
+
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}