summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-05 01:25:43 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-06 06:23:30 +1200
commit82cffb699bd1e6e9dfcc86cca4e4662c12a21e57 (patch)
treefb19f9455bde4b35ac1d2ff1195290fa89c74107
parentdev-perl/Cairo: -r bump for CFLAGS love (diff)
downloadgentoo-82cffb699bd1e6e9dfcc86cca4e4662c12a21e57.tar.gz
gentoo-82cffb699bd1e6e9dfcc86cca4e4662c12a21e57.tar.bz2
gentoo-82cffb699bd1e6e9dfcc86cca4e4662c12a21e57.zip
dev-perl/Cairo-GObject: -r bump for CFLAGS love
- Ensure cairo in DEPEND (for link) - Ensure CFLAGS passed to make/compiler Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Cairo-GObject/Cairo-GObject-1.5.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Cairo-GObject/Cairo-GObject-1.5.0-r1.ebuild b/dev-perl/Cairo-GObject/Cairo-GObject-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..81a8a90d9066
--- /dev/null
+++ b/dev-perl/Cairo-GObject/Cairo-GObject-1.5.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=1.005
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Integrate Cairo into the Glib type system"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/cairo[glib]
+ >=dev-perl/glib-perl-1.224.0
+ >=dev-perl/Cairo-1.80.0
+"
+DEPEND="
+ x11-libs/cairo[glib]
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.200.0
+ >=dev-perl/ExtUtils-PkgConfig-1.0.0
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}