summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-02-15 15:56:11 -0500
committerMike Gilbert <floppym@gentoo.org>2019-02-15 15:56:11 -0500
commit82d04f6fd11ef6601e17364aaee1c77995a16adc (patch)
treeca962274f42010110595b7f82016921a3e1f289b
parentprofiles: Drop mask for removed app-emacs/tdtd. (diff)
downloadgentoo-82d04f6fd11ef6601e17364aaee1c77995a16adc.tar.gz
gentoo-82d04f6fd11ef6601e17364aaee1c77995a16adc.tar.bz2
gentoo-82d04f6fd11ef6601e17364aaee1c77995a16adc.zip
www-client/chromium: drop obsolete patches
Closes: https://bugs.gentoo.org/673456 Package-Manager: Portage-2.3.59_p2, Repoman-2.3.12_p67 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--www-client/chromium/chromium-72.0.3626.96.ebuild4
-rw-r--r--www-client/chromium/files/chromium-math.h-r0.patch29
-rw-r--r--www-client/chromium/files/chromium-memcpy-r0.patch35
-rw-r--r--www-client/chromium/files/chromium-stdint.patch21
-rw-r--r--www-client/chromium/files/chromium-webrtc-r0.patch34
5 files changed, 0 insertions, 123 deletions
diff --git a/www-client/chromium/chromium-72.0.3626.96.ebuild b/www-client/chromium/chromium-72.0.3626.96.ebuild
index b34fe2996fce..fd355e67ee9c 100644
--- a/www-client/chromium/chromium-72.0.3626.96.ebuild
+++ b/www-client/chromium/chromium-72.0.3626.96.ebuild
@@ -141,10 +141,6 @@ GTK+ icon theme.
PATCHES=(
"${FILESDIR}/chromium-compiler-r7.patch"
"${FILESDIR}/chromium-widevine-r4.patch"
- "${FILESDIR}/chromium-webrtc-r0.patch"
- "${FILESDIR}/chromium-memcpy-r0.patch"
- "${FILESDIR}/chromium-math.h-r0.patch"
- "${FILESDIR}/chromium-stdint.patch"
)
pre_build_checks() {
diff --git a/www-client/chromium/files/chromium-math.h-r0.patch b/www-client/chromium/files/chromium-math.h-r0.patch
deleted file mode 100644
index 6c7c747053a1..000000000000
--- a/www-client/chromium/files/chromium-math.h-r0.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 9f63f94a11abc34d40ede8b8712fa15b5844a8c0 Mon Sep 17 00:00:00 2001
-From: Tom Anderson <thomasanderson@chromium.org>
-Date: Sat, 27 Jan 2018 20:03:37 +0000
-Subject: [PATCH] Fix build with glibc 2.27
-
-BUG=806340
-TBR=hamelphi@chromium.org
-
-Change-Id: Ib4e5091212d874d9ad88f3e9a1fdfee3ed7e0d5e
-Reviewed-on: https://chromium-review.googlesource.com/890059
-Reviewed-by: Thomas Anderson <thomasanderson@chromium.org>
-Reviewed-by: Philippe Hamel <hamelphi@chromium.org>
-Commit-Queue: Thomas Anderson <thomasanderson@chromium.org>
-Cr-Commit-Position: refs/heads/master@{#532249}
----
-
-diff --git a/components/assist_ranker/ranker_example_util.cc b/components/assist_ranker/ranker_example_util.cc
-index 54d4dbd..ceedd8f 100644
---- a/components/assist_ranker/ranker_example_util.cc
-+++ b/components/assist_ranker/ranker_example_util.cc
-@@ -2,6 +2,8 @@
- // Use of this source code is governed by a BSD-style license that can be
- // found in the LICENSE file.
-
-+#include <math.h>
-+
- #include "components/assist_ranker/ranker_example_util.h"
- #include "base/bit_cast.h"
- #include "base/format_macros.h"
diff --git a/www-client/chromium/files/chromium-memcpy-r0.patch b/www-client/chromium/files/chromium-memcpy-r0.patch
deleted file mode 100644
index dd2fd57d26a6..000000000000
--- a/www-client/chromium/files/chromium-memcpy-r0.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 4942f56ceb6d60d6f54ebca8e6eba8ba01c278e8 Mon Sep 17 00:00:00 2001
-From: Tomas Popela <tomas.popela@gmail.com>
-Date: Thu, 7 Dec 2017 22:33:34 +0000
-Subject: [PATCH] memcpy used without including string.h
-
-Compiling Chromium with Clang 4.0.1 and using libstdc++ will fail on using
-memcpy without including string.h.
-
-Cq-Include-Trybots: master.tryserver.blink:linux_trusty_blink_rel;master.tryserver.chromium.android:android_optional_gpu_tests_rel
-Change-Id: Idced1d5de3baf6b520d4a2d61774120642ead1a8
-Reviewed-on: https://chromium-review.googlesource.com/813737
-Reviewed-by: Thomas Anderson <thomasanderson@chromium.org>
-Reviewed-by: vmpstr <vmpstr@chromium.org>
-Commit-Queue: Thomas Anderson <thomasanderson@chromium.org>
-Cr-Commit-Position: refs/heads/master@{#522579}
----
- cc/paint/raw_memory_transfer_cache_entry.cc | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/cc/paint/raw_memory_transfer_cache_entry.cc b/cc/paint/raw_memory_transfer_cache_entry.cc
-index 9e4660c685ee..95ad50b1a338 100644
---- a/cc/paint/raw_memory_transfer_cache_entry.cc
-+++ b/cc/paint/raw_memory_transfer_cache_entry.cc
-@@ -4,6 +4,8 @@
-
- #include "cc/paint/raw_memory_transfer_cache_entry.h"
-
-+#include <string.h>
-+
- namespace cc {
-
- ClientRawMemoryTransferCacheEntry::ClientRawMemoryTransferCacheEntry(
---
-2.15.1
-
diff --git a/www-client/chromium/files/chromium-stdint.patch b/www-client/chromium/files/chromium-stdint.patch
deleted file mode 100644
index 877443954faa..000000000000
--- a/www-client/chromium/files/chromium-stdint.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 0235c2b657d936f3cdb09053776e5929fc84704b Mon Sep 17 00:00:00 2001
-From: Tomas Popela <tomas.popela@gmail.com>
-Date: Wed, 31 Jan 2018 18:57:07 +0000
-Subject: [PATCH] Add missing stdint include
-
-diff --git a/chrome/browser/vr/sample_queue.cc b/chrome/browser/vr/sample_queue.cc
-index c2ca777ce90c..53cb3aab1576 100644
---- a/chrome/browser/vr/sample_queue.cc
-+++ b/chrome/browser/vr/sample_queue.cc
-@@ -2,6 +2,8 @@
- // Use of this source code is governed by a BSD-style license that can be
- // found in the LICENSE file.
-
-+#include <stdint.h>
-+
- #include "chrome/browser/vr/sample_queue.h"
-
- namespace vr {
---
-2.16.2
-
diff --git a/www-client/chromium/files/chromium-webrtc-r0.patch b/www-client/chromium/files/chromium-webrtc-r0.patch
deleted file mode 100644
index e14b185acb9b..000000000000
--- a/www-client/chromium/files/chromium-webrtc-r0.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 7f90e2cceda0458cf56026eb6ccffb961a47804b Mon Sep 17 00:00:00 2001
-From: Raphael Kubo da Costa <raphael.kubo.da.costa@intel.com>
-Date: Fri, 13 Oct 2017 15:49:32 +0200
-Subject: [PATCH] IWYU: Include math.h for round(3).
-
-math.h was being implicitly included, which can break the build with
-alternative libc implementations.
-
-Bug: None
-Change-Id: I969b320b65d0f44abb33d3e1036cfbcb859a4952
-Reviewed-on: https://webrtc-review.googlesource.com/9384
-Reviewed-by: Tommi <tommi@webrtc.org>
-Commit-Queue: Raphael Kubo da Costa (rakuco) <raphael.kubo.da.costa@intel.com>
-Cr-Commit-Position: refs/heads/master@{#20292}
----
- p2p/base/port.cc | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/p2p/base/port.cc b/p2p/base/port.cc
-index a1b478d11..81aa0aadb 100644
---- a/third_party/webrtc/p2p/base/port.cc
-+++ b/third_party/webrtc/p2p/base/port.cc
-@@ -10,6 +10,8 @@
-
- #include "p2p/base/port.h"
-
-+#include <math.h>
-+
- #include <algorithm>
- #include <vector>
-
---
-2.15.0.rc2
-