summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-17 03:13:06 +0000
committerSam James <sam@gentoo.org>2024-03-17 03:13:06 +0000
commit82d0f1038dba761dcebeb6ca98fe4d4069afe0ed (patch)
tree52e1cad01a4a8d0d02cfda9f6bad758d06e3d213
parentgnome-extra/cinnamon-settings-daemon: fix modern C issue (diff)
downloadgentoo-82d0f1038dba761dcebeb6ca98fe4d4069afe0ed.tar.gz
gentoo-82d0f1038dba761dcebeb6ca98fe4d4069afe0ed.tar.bz2
gentoo-82d0f1038dba761dcebeb6ca98fe4d4069afe0ed.zip
gnome-extra/gnome-calendar: fix modern C issue
Closes: https://bugs.gentoo.org/926638 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--gnome-extra/gnome-calendar/files/gnome-calendar-45.1-c99.patch23
-rw-r--r--gnome-extra/gnome-calendar/gnome-calendar-45.1-r1.ebuild51
2 files changed, 74 insertions, 0 deletions
diff --git a/gnome-extra/gnome-calendar/files/gnome-calendar-45.1-c99.patch b/gnome-extra/gnome-calendar/files/gnome-calendar-45.1-c99.patch
new file mode 100644
index 000000000000..1a3411d335fa
--- /dev/null
+++ b/gnome-extra/gnome-calendar/files/gnome-calendar-45.1-c99.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/926638
+https://gitlab.gnome.org/GNOME/gnome-calendar/-/commit/2c33d98d82386b0d5e9057c8ba532efc6e202818
+
+From 2c33d98d82386b0d5e9057c8ba532efc6e202818 Mon Sep 17 00:00:00 2001
+From: David King <amigadave@amigadave.com>
+Date: Mon, 26 Feb 2024 11:55:29 +0000
+Subject: [PATCH] weather-service: Fix incompatible pointer types
+
+--- a/src/weather/gcal-weather-service.c
++++ b/src/weather/gcal-weather-service.c
+@@ -486,8 +486,8 @@ preprocess_gweather_reports (GcalWeatherService *self,
+ GSList *iter = NULL; /* unowned */
+ GDate cur_gdate;
+ glong first_tomorrow_dtime = -1;
+- glong today_unix;
+- glong unix_now;
++ gint64 today_unix;
++ gint64 unix_now;
+ guint i;
+
+ /*
+--
+GitLab
diff --git a/gnome-extra/gnome-calendar/gnome-calendar-45.1-r1.ebuild b/gnome-extra/gnome-calendar/gnome-calendar-45.1-r1.ebuild
new file mode 100644
index 000000000000..474e4f90fad4
--- /dev/null
+++ b/gnome-extra/gnome-calendar/gnome-calendar-45.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson virtualx xdg
+
+DESCRIPTION="Manage your online calendars with simple and modern interface"
+HOMEPAGE="https://wiki.gnome.org/Apps/Calendar"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/libical-1.0.1:0=
+ >=gnome-base/gsettings-desktop-schemas-3.21.2
+ >=gnome-extra/evolution-data-server-3.45.1:=[gtk]
+ net-libs/libsoup:3.0
+ >=gui-libs/libadwaita-1.4_alpha:1
+ >=dev-libs/glib-2.67.5:2
+ >=gui-libs/gtk-4.11.2:4
+ >=dev-libs/libgweather-4.2.0:4=
+ >=app-misc/geoclue-2.4:2.0
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/gnome-calendar-45.1-c99.patch
+)
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}