summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2023-07-05 20:16:57 +0200
committerAmy Liffey <amynka@gentoo.org>2023-07-05 20:20:03 +0200
commit82e1a31178eecd0ee1551766a1aa70df60920f56 (patch)
treea0cb367f9cf704edf5676ec2dce04c439b3abf77
parentwww-apache/mod_qos: Fix incompatible pointer to integer conversion (diff)
downloadgentoo-82e1a31178eecd0ee1551766a1aa70df60920f56.tar.gz
gentoo-82e1a31178eecd0ee1551766a1aa70df60920f56.tar.bz2
gentoo-82e1a31178eecd0ee1551766a1aa70df60920f56.zip
app-misc/khal: add 0.11.2
Closes: https://bugs.gentoo.org/908402 Signed-off-by: Amy Liffey <amynka@gentoo.org>
-rw-r--r--app-misc/khal/Manifest1
-rw-r--r--app-misc/khal/khal-0.11.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/khal/Manifest b/app-misc/khal/Manifest
index 009660e83961..b212bb168f98 100644
--- a/app-misc/khal/Manifest
+++ b/app-misc/khal/Manifest
@@ -1 +1,2 @@
DIST khal-0.11.1.tar.gz 193942 BLAKE2B 12f98781b9a64710537f7728a087f24ef1d73600e957eac7b699948047c1676a9c91a38a415741c6acd94a7ba72014d4b009425edab249225c8bef23b94c0387 SHA512 c4fd25dc4981f4937562949b78f81d3e57b7ef54f7f6d96855645ca239eea9dec7ee6f3c957a67261e7ae2975ab55b36a686db476b03f4fd0bacce94e834b239
+DIST khal-0.11.2.tar.gz 196986 BLAKE2B 5802b5c7a715ec300feb2618400753fe7f109a894c6bf5cc82eebc349c5c4f651894f14584c91bd479e62f5fa65fd0e400f7c04fb2cc4bee8fef6ffec891216e SHA512 378a81c9f9a21a4af77ccdc5eabbcb62d109bcf5f2e2d3407c6fb504e15efd7dde545428153673cfeb46f60d9e9921efcad6805db2944884f124053e7922ab45
diff --git a/app-misc/khal/khal-0.11.2.ebuild b/app-misc/khal/khal-0.11.2.ebuild
new file mode 100644
index 000000000000..d7fb643f20fa
--- /dev/null
+++ b/app-misc/khal/khal-0.11.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A CalDAV based calendar"
+HOMEPAGE="https://lostpackets.de/khal/ https://github.com/pimutils/khal"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-log[${PYTHON_USEDEP}]
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/vdirsyncer[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.rst README.rst khal.conf.sample )
+
+distutils_enable_tests pytest