summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-25 22:33:07 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-25 22:33:07 +0200
commit82ee129f3439bbe7347b6a7d13d5159b8cd0661f (patch)
tree26b32c2f9341b94d39eeea758022657263c2e64f
parentdev-python/gssapi: drop 1.8.1 (diff)
downloadgentoo-82ee129f.tar.gz
gentoo-82ee129f.tar.bz2
gentoo-82ee129f.zip
dev-python/hcloud-python: drop 1.18.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/hcloud-python/Manifest1
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.18.0.ebuild40
2 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index f3fe8c03acb3..150e9e1f1054 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1,2 +1 @@
-DIST hcloud-python-1.18.0.gh.tar.gz 99047 BLAKE2B c32b048653bea1910ed8a82d0e08603a154dc89208c0cf8b9e046078277460fedffe6568c7c3cf56a8408bb0423d38464c4fd57dded4523886560823e3ee65da SHA512 8339b5da4df7f5e1f38fbd7a3f205387bfd7a65a7c4eaa757c4c35056b70c06230fe9b8a597b54bac082af975184bd5ef33a6e2747b60a67cc34d6771435452c
DIST hcloud-python-1.18.1.gh.tar.gz 99042 BLAKE2B 159b2fb29021ca7993f75c4731867ed1bc57e2c9a3cf68a45acf43bb45e9a0862717907d1dfce45c960064ad82b71422e76b290db3516ea3744be95797db5e1e SHA512 6d172c214d25ae846b5561e4caa6b70d4f4e765e064ae971d5b216ceb743ab269f735e2c9adb68f1cf99ef429621b6998a34c8c7befa6d527dc3b774c0639bae
diff --git a/dev-python/hcloud-python/hcloud-python-1.18.0.ebuild b/dev-python/hcloud-python/hcloud-python-1.18.0.ebuild
deleted file mode 100644
index f0eb128c1b5d..000000000000
--- a/dev-python/hcloud-python/hcloud-python-1.18.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
-
-DESCRIPTION="Official Hetzner Cloud python library"
-HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
-SRC_URI="
- https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="doc examples"
-
-RDEPEND="
- >=dev-python/future-0.17.1[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme
-distutils_enable_tests pytest
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
-
-python_test() {
- # Integration tests need docker:
- # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
- epytest --ignore tests/integration
-}