summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Genasci <fedeliallalinea@gmail.com>2018-01-03 08:28:32 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-03 09:18:21 +0100
commit8324783fb766a08e4f57a5490e4574152c13e2ae (patch)
tree358ab19727546540f9731044e8873194ba612c8c
parentdev-python/click: stable 6.7 for hppa, bug #630320 (diff)
downloadgentoo-8324783f.tar.gz
gentoo-8324783f.tar.bz2
gentoo-8324783f.zip
dev-db/sqlcl-bin: version bump to 17.4.0.354.2224
-rw-r--r--dev-db/sqlcl-bin/Manifest3
-rw-r--r--dev-db/sqlcl-bin/sqlcl-bin-17.4.0.354.2224.ebuild48
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-db/sqlcl-bin/Manifest b/dev-db/sqlcl-bin/Manifest
index 9e91e6dfe48d..40d3ff439a54 100644
--- a/dev-db/sqlcl-bin/Manifest
+++ b/dev-db/sqlcl-bin/Manifest
@@ -1 +1,2 @@
-DIST sqlcl-17.3.0.271.1943-no-jre.zip 19672343 SHA256 1fde4252453474a671bc67a90e0e1077d63d804f9ee63c1280d81fa29e1952b0 SHA512 75e56ab042b34ca3290b07b4d4eb182dcf264a4bb8392f8a6942df7ca7041b1d25dc70d388f0f5ecd03decff22d040cfc3a4d58f0ec656af334ddd6531f5bbb4 WHIRLPOOL c7267c61df80e9984e71b8161cd34c8028706614ce0dcb1ff2c7c2424137d65fd90a312106e7e0aafe6c2d36e8e7ce2abbed477aa453b07dd7d6608c8baa3933
+DIST sqlcl-17.3.0.271.1943-no-jre.zip 19672343 BLAKE2B 976b12f16f206d93f7cc628532d736e13c6cd8e502024b369906695365220a250481a02ab5ef7047b6899743a1bdc751ebcbdb58910cb4f75463be795e265996 SHA512 75e56ab042b34ca3290b07b4d4eb182dcf264a4bb8392f8a6942df7ca7041b1d25dc70d388f0f5ecd03decff22d040cfc3a4d58f0ec656af334ddd6531f5bbb4
+DIST sqlcl-17.4.0.354.2224-no-jre.zip 19731560 BLAKE2B 0ee78a39e5be5d2c23a583cf3f4790897d79e1b082036d30a071fa629912e31c3fc3dbb0e873f4013ba6d41c27c8e1d99aff851922202983842cbf09cf1c6b0b SHA512 d03e949755fc3c99661d3b87dc4576fd4cb0edd33fa2b05818bbb26cd6d066d221ad6bcc0fc2f1453a80351b82e5698a193730cbabbf84a55607a118c39b4243
diff --git a/dev-db/sqlcl-bin/sqlcl-bin-17.4.0.354.2224.ebuild b/dev-db/sqlcl-bin/sqlcl-bin-17.4.0.354.2224.ebuild
new file mode 100644
index 000000000000..2da7c12ea1eb
--- /dev/null
+++ b/dev-db/sqlcl-bin/sqlcl-bin-17.4.0.354.2224.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Oracle SQLcl is the new SQL*Plus"
+HOMEPAGE="http://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/index.html"
+SRC_URI="${MY_P}-no-jre.zip"
+RESTRICT="bindist fetch mirror"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="virtual/jre:1.8
+ dev-java/java-config:2
+ dev-db/oracle-instantclient"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ eerror "Please go to"
+ eerror " ${HOMEPAGE}"
+ eerror "and download"
+ eerror " Command Line - SQLcl"
+ eerror " ${SRC_URI}"
+ eerror "and move it to DISTDIR directory."
+}
+
+src_prepare() {
+ default
+ find ./ \( -iname "*.bat" -or -iname "*.exe" \) -exec rm {} + || die "remove files failed"
+ mv sqlcl/bin/sql sqlcl/bin/"${MY_PN}" || die "rename executable failed"
+}
+
+src_install() {
+ exeinto "/opt/${MY_PN}/bin/"
+ doexe "${S}/${MY_PN}/bin/${MY_PN}"
+
+ insinto "/opt/${MY_PN}/lib/"
+ doins -r "${S}/${MY_PN}/lib/"*
+
+ dosym "${ED%/}/opt/${MY_PN}/bin/${MY_PN}" "/opt/bin/${MY_PN}"
+}