summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-11-15 22:59:51 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-11-15 23:39:06 +0100
commit832ba9c87c6a3f7ceab51590e3d02775aeb8d824 (patch)
treebe20fb1dd078e5da34eb6faee08ca5a92b31e4cc
parentdev-util/intel-graphics-compiler: amd64 stable (diff)
downloadgentoo-832ba9c87c6a3f7ceab51590e3d02775aeb8d824.tar.gz
gentoo-832ba9c87c6a3f7ceab51590e3d02775aeb8d824.tar.bz2
gentoo-832ba9c87c6a3f7ceab51590e3d02775aeb8d824.zip
dev-util/intel-graphics-compiler: drop 1.0.12149.1
Closes: https://bugs.gentoo.org/873028 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-util/intel-graphics-compiler/Manifest1
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.12149.1.ebuild85
2 files changed, 0 insertions, 86 deletions
diff --git a/dev-util/intel-graphics-compiler/Manifest b/dev-util/intel-graphics-compiler/Manifest
index 3f3b03dbd1c1..807155d51172 100644
--- a/dev-util/intel-graphics-compiler/Manifest
+++ b/dev-util/intel-graphics-compiler/Manifest
@@ -1,2 +1 @@
-DIST intel-graphics-compiler-1.0.12149.1.tar.gz 8874232 BLAKE2B b6195741282290561ee669574b19a9d96dd9695ea6358932f4c54946ff7b2a0315f905e9445419349131c2a424b630b8197a944bbd46a3232bd841be50f4f2e8 SHA512 1c9f2a6e119713173db527d8dc891269606db2a57a9c0043c82556e79a77d83bab31b732557e8130f36b99a54b551e8ff6d6104b3d75ef081d9f16811abbe8db
DIST intel-graphics-compiler-1.0.12260.1.tar.gz 8887984 BLAKE2B 626b5f2bd189ba9b2933b9d65227ca1552484f73f7398b2a763744d21a4ea189987e4eb08e9e7f09898fb49568b59a2c45298363495c1759fec9927a95cf4478 SHA512 4223e9c8213c7e6cf3539d955394a0a4a39cb8d2114ce18ccaeeb0b36a91ca6fc6a314fa9d9db24929fa7cd6b86ff8b82f369f35dd80e5df49b23ac9cd3a519b
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.12149.1.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.12149.1.ebuild
deleted file mode 100644
index 63b90728f8c7..000000000000
--- a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.12149.1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_BUILD_TYPE="Release"
-LLVM_MAX_SLOT="13"
-MY_PN="igc"
-MY_P="${MY_PN}-${PV}"
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit cmake flag-o-matic llvm python-any-r1
-
-DESCRIPTION="LLVM-based OpenCL compiler for OpenCL targetting Intel Gen graphics hardware"
-HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
-SRC_URI="https://github.com/intel/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="debug"
-
-DEPEND="
- dev-libs/opencl-clang:${LLVM_MAX_SLOT}=
- dev-util/spirv-tools
- =sys-devel/lld-${LLVM_MAX_SLOT}*
- sys-devel/llvm:${LLVM_MAX_SLOT}=
-"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="
- =sys-devel/lld-${LLVM_MAX_SLOT}*
- ${PYTHON_DEPS}
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.0.9-no_Werror.patch"
- "${FILESDIR}/${PN}-1.0.8173-opencl-clang_version.patch"
- "${FILESDIR}/${PN}-1.0.8365-disable-git.patch"
- "${FILESDIR}/${PN}-1.0.11485-include-opencl-c.patch"
-)
-
-pkg_setup() {
- llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- # Get LLVM version
- local llvm_version="$(best_version -d sys-devel/llvm:${LLVM_MAX_SLOT})"
-
- # See https://github.com/intel/intel-graphics-compiler/issues/212
- append-ldflags -Wl,-z,undefs
-
- # See https://bugs.gentoo.org/718824
- ! use debug && append-cppflags -DNDEBUG
-
- local mycmakeargs=(
- -DCCLANG_INCLUDE_PREBUILDS_DIR="/usr/lib/clang/${llvm_version##*-}/include"
- -DCCLANG_SONAME_VERSION="${LLVM_MAX_SLOT}"
- -DCMAKE_LIBRARY_PATH="$(get_llvm_prefix ${LLVM_MAX_SLOT})/$(get_libdir)"
- -DIGC_OPTION__ARCHITECTURE_TARGET="Linux64"
- -DIGC_OPTION__CLANG_MODE="Prebuilds"
- -DIGC_OPTION__LINK_KHRONOS_SPIRV_TRANSLATOR="ON"
- -DIGC_OPTION__LLD_MODE="Prebuilds"
- -DIGC_OPTION__LLDELF_H_DIR="${EPREFIX}/usr/include/lld/Common"
- -DIGC_OPTION__LLVM_MODE="Prebuilds"
- -DIGC_OPTION__LLVM_PREFERRED_VERSION="${llvm_version##*-}"
- -DIGC_OPTION__SPIRV_TOOLS_MODE="Prebuilds"
- -DIGC_OPTION__SPIRV_TRANSLATOR_MODE="Prebuilds"
- -DIGC_OPTION__USE_PREINSTALLED_SPRIV_HEADERS="ON"
- -DINSTALL_GENX_IR="ON"
- -DSPIRVLLVMTranslator_INCLUDE_DIR="${EPREFIX}/usr/lib/llvm/${LLVM_MAX_SLOT}/include/LLVMSPIRVLib"
- -Wno-dev
-
- # Compilation with VectorCompiler causes currently a segfault.
- # See https://github.com/intel/intel-graphics-compiler/issues/236
- -DIGC_BUILD__VC_ENABLED="OFF"
- # -DIGC_OPTION__VC_INTRINSICS_MODE="Prebuilds"
- )
-
- cmake_src_configure
-}