summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-13 21:05:25 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-13 21:09:11 +0200
commit8330d6312f5833d9c20b8447d1759501107434e5 (patch)
tree9e0f9dbe84ea2b72b9bff09b57bbbfabf4ce9dc5
parentdev-python/ruamel-yaml: support python3_10 (diff)
downloadgentoo-8330d6312f5833d9c20b8447d1759501107434e5.tar.gz
gentoo-8330d6312f5833d9c20b8447d1759501107434e5.tar.bz2
gentoo-8330d6312f5833d9c20b8447d1759501107434e5.zip
dev-python/vdf: support python3_10
Had to be patched to import ABCs from collections.abc rather than collections directly (deprecated since 3.3, originally scheduled to be disallowed in 3.9, eventually stopped working in 3.10), with that taken care of builds, tests and installs fine. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/vdf/files/vdf-3.3-collections_abc.patch11
-rw-r--r--dev-python/vdf/vdf-3.3.ebuild5
2 files changed, 14 insertions, 2 deletions
diff --git a/dev-python/vdf/files/vdf-3.3-collections_abc.patch b/dev-python/vdf/files/vdf-3.3-collections_abc.patch
new file mode 100644
index 000000000000..22c647601688
--- /dev/null
+++ b/dev-python/vdf/files/vdf-3.3-collections_abc.patch
@@ -0,0 +1,11 @@
+--- a/vdf/vdict.py
++++ b/vdf/vdict.py
+@@ -5,7 +5,7 @@
+ _iter_values = 'values'
+ _range = range
+ _string_type = str
+- import collections as _c
++ import collections.abc as _c
+ class _kView(_c.KeysView):
+ def __iter__(self):
+ return self._mapping.iterkeys()
diff --git a/dev-python/vdf/vdf-3.3.ebuild b/dev-python/vdf/vdf-3.3.ebuild
index b0147e4aab7a..d4f3fdcce980 100644
--- a/dev-python/vdf/vdf-3.3.ebuild
+++ b/dev-python/vdf/vdf-3.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -17,6 +17,7 @@ KEYWORDS="amd64"
PATCHES=(
"${FILESDIR}"/${PN}-3.2-mock_from_stdlib.patch
+ "${FILESDIR}"/${PN}-3.3-collections_abc.patch
)
distutils_enable_tests pytest