summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-01 08:50:17 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-01 09:32:11 +0100
commit833bbfa9b6ef4440d91fcdd6643cbedf85b2addc (patch)
tree6433c898160961d4d81476368b6e1f69d3682696
parentdev-python/pikepdf: Bump to 4.0.0 (diff)
downloadgentoo-833bbfa9.tar.gz
gentoo-833bbfa9.tar.bz2
gentoo-833bbfa9.zip
dev-python/async_timeout: Bump to 4.0.0a3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/async_timeout/Manifest1
-rw-r--r--dev-python/async_timeout/async_timeout-4.0.0_alpha3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/async_timeout/Manifest b/dev-python/async_timeout/Manifest
index f929a7fd11ef..8679d7982d2a 100644
--- a/dev-python/async_timeout/Manifest
+++ b/dev-python/async_timeout/Manifest
@@ -1 +1,2 @@
DIST async-timeout-3.0.1.tar.gz 9724 BLAKE2B f18ae75969b7048469fe22949f25ea25da3fdbf08b98a16b5d5ffe823060a75e6de9ed764727e08d4344c79426e9c89013d49522f20ed62e6fbe912b5c7a8787 SHA512 fd30842671a79edfd52c7350e7fb2120533a6d97b44975f7b071ce2cbde43443bd5bbe1f2ad0ad3ab2156e1987b9e58e0c149b0ecfea8674eb0cb78eee79c986
+DIST async-timeout-4.0.0a3.tar.gz 11386 BLAKE2B 8918878c4edd64c70d831ddd05e3235c3c7cc116a99755205b7624df52cacfb61bf4e80083c85d93e420fbf18e7da16ee3ebc796c5a4890e2801885b670a494a SHA512 04775ea30ffba90a4b604ef040df24a6a2711fd3e2c3b45d1ab87ae3487f216458f44bbfb2c85498bef286acca90af43d8b3b95cf22244027c0a48494ef84e7a
diff --git a/dev-python/async_timeout/async_timeout-4.0.0_alpha3.ebuild b/dev-python/async_timeout/async_timeout-4.0.0_alpha3.ebuild
new file mode 100644
index 000000000000..ec9fda7ab9ba
--- /dev/null
+++ b/dev-python/async_timeout/async_timeout-4.0.0_alpha3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P=${PN/_/-}-${PV/_alpha/a}
+DESCRIPTION="Timeout context manager for asyncio programs"
+HOMEPAGE="https://github.com/aio-libs/async-timeout"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pointless dep on pytest-cov
+ sed -i -e '/addopts/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest -p no:aiohttp
+}