summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-04-01 21:25:18 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-04-01 21:25:18 +0200
commit833e853ea470bb58ffd4e86bdece85c4a6412696 (patch)
treef30f1c054e63d018a573db01d2642db9f679655b
parentgames-server/bedrock-server: drop 1.19.63.01, 1.19.71.02, 1.19.72.01 (diff)
downloadgentoo-833e853ea470bb58ffd4e86bdece85c4a6412696.tar.gz
gentoo-833e853ea470bb58ffd4e86bdece85c4a6412696.tar.bz2
gentoo-833e853ea470bb58ffd4e86bdece85c4a6412696.zip
net-libs/libupnp: add 1.14.16
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--net-libs/libupnp/Manifest1
-rw-r--r--net-libs/libupnp/libupnp-1.14.16.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
index b38ba9f10a27..2d4bfa6cdcb0 100644
--- a/net-libs/libupnp/Manifest
+++ b/net-libs/libupnp/Manifest
@@ -1 +1,2 @@
DIST libupnp-1.14.15.tar.gz 809246 BLAKE2B 5918f41b64fe5e4a0209058f4706d724d0fcad74c8e3bfc2a54d6d5a1af253d4461ec43b0c896f1da14dcb3fb0925cbae3bc6eb015380e1cd23a3d88e6ed656f SHA512 dde2563eaacdd288066012f001b819ec25ab51bc36aef23db71d2eb67eef778b6b2b10b35a2f6b3041ecef20167e873e1c54e17fc4a26e8d1d9f408e2050279d
+DIST libupnp-1.14.16.tar.gz 810632 BLAKE2B f9cebb6f0f5faea07e003f433100d4789e2f59d16a1d1733e1a644ca49ea8fc43b080359b6106c84e4681b6c491ecbbc6373766aaf962d6b97372dfd4abf4bd2 SHA512 f02d72415ec4891e019724b5774aed2bd470d64ff1f6c179140a3e61bfb34794f0e6069d5f4baf0d8260aae09eab607a61575f02c4f853616180aec7f701abd3
diff --git a/net-libs/libupnp/libupnp-1.14.16.ebuild b/net-libs/libupnp/libupnp-1.14.16.ebuild
new file mode 100644
index 000000000000..f2542c3b3894
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.14.16.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN="pupnp"
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-release-${PV}"
+
+LICENSE="BSD"
+SLOT="0/17"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="blocking-tcp debug doc +reuseaddr samples +ssl static-libs"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.14.12-disable-network-tests.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable blocking-tcp blocking-tcp-connections)
+ $(use_enable debug)
+ --enable-ipv6
+ $(use_enable reuseaddr)
+ $(use_enable samples)
+ $(use_enable ssl open_ssl)
+ $(use_enable static-libs static)
+ )
+
+ econf ${myeconfargs[@]}
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}