summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-06-18 16:39:54 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-06-18 16:39:54 -0400
commit835c7ad73f684e9947e69da3bdf67b78ea4fcf79 (patch)
tree4e96bdbac2384c238c81042ee63b072ad1350efb
parentmedia-radio/js8call: bump (diff)
downloadgentoo-835c7ad73f684e9947e69da3bdf67b78ea4fcf79.tar.gz
gentoo-835c7ad73f684e9947e69da3bdf67b78ea4fcf79.tar.bz2
gentoo-835c7ad73f684e9947e69da3bdf67b78ea4fcf79.zip
dev-python/fido2: bump to 0.7.0
Package-Manager: Portage-2.3.67, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
-rw-r--r--dev-python/fido2/Manifest1
-rw-r--r--dev-python/fido2/fido2-0.7.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
index 742dad4e5124..c88ce50f4b48 100644
--- a/dev-python/fido2/Manifest
+++ b/dev-python/fido2/Manifest
@@ -2,3 +2,4 @@ DIST fido2-0.3.0.tar.gz 125907 BLAKE2B 95054f258c775ac3b4f65608fd3b62ec4165a568c
DIST fido2-0.4.0.tar.gz 141714 BLAKE2B 3d57ef1598d2c84cea8a98e75cdef96b77807d4eb5951515560b43655a48bb0816c4e05ef39314b13b6bad84509e09145aeab5727a9fc6cba65ddf42f588b007 SHA512 4eb95a95e1f5b8b49267bc0a11e5501bd041a211ac8a6249ff9cc26ebb0b155b9d16494c18391a14feecb197d61dc50c8530b2ab38ba7e9dc600276abd6f8bcf
DIST fido2-0.5.0.tar.gz 161562 BLAKE2B 20d4f6c4e54366a26d5a56a84a6ff84bec0f0e22107aa612db721df8a5186a2129373ae609fb58a27008dc700b4b92d607fc2bf16aab7ac6bff8d9e7219204aa SHA512 fa83848e179b9208e2a701a3330faa1dde75e5e23133540eaec896145dbde376bc424a5e59865d3cf90c5765882e22530e96df2491101d2b5dcb22cfc4bcbb87
DIST fido2-0.6.0.tar.gz 163137 BLAKE2B 3a30d4267a1aae00eac8fa8c05065163f992b72895097aca95dba72300bd9c30373c7537a867e532949af779e8e7528e1a3aad8f04cb0170678675294757b5d4 SHA512 1fb8e591480ac2ac9c405e4fc74895d55d630e462626f849952193c3ae6720104cca1da47af1f89adbcc026034f69dba12fc38577b00f9802434db2162d0d1d5
+DIST fido2-0.7.0.tar.gz 171787 BLAKE2B 6458a606ecbbd22ac7c49b2e32b46e43c0ca184645fff4c54e0204f044a415db05b3e7187b6138e4d1b67dad9ed5faf3eb561b11b391b5105bac4299481bd95d SHA512 65fdaeeb1932873fb2ae86257182eb6098d6bf4ce5ed45336327bd3e9040eddccd7f7559ece58d9bdcbfe8c98c2eb8646069556a6d00035fef5eade4907a45d8
diff --git a/dev-python/fido2/fido2-0.7.0.ebuild b/dev-python/fido2/fido2-0.7.0.ebuild
new file mode 100644
index 000000000000..bc1d3938cb32
--- /dev/null
+++ b/dev-python/fido2/fido2-0.7.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python based FIDO 2.0 library"
+HOMEPAGE="https://github.com/Yubico/python-fido2"
+SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ examples? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}