summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-02-06 22:40:58 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-02-06 22:40:58 +0900
commit836369743b23ce8f4973458be9ec3d9ab1c40bd9 (patch)
tree01410326c88eade4e4d7ee3537dcf1dc41267570
parentmedia-libs/libsixel: drop old (diff)
downloadgentoo-83636974.tar.gz
gentoo-83636974.tar.bz2
gentoo-83636974.zip
media-libs/libsixel: new upstream release
Package-Manager: portage-2.3.3
-rw-r--r--media-libs/libsixel/Manifest1
-rw-r--r--media-libs/libsixel/libsixel-1.7.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/libsixel/Manifest b/media-libs/libsixel/Manifest
index a5462e93d200..d6bcd7a2e89d 100644
--- a/media-libs/libsixel/Manifest
+++ b/media-libs/libsixel/Manifest
@@ -1 +1,2 @@
DIST libsixel-1.7.2.tar.gz 4760634 SHA256 8e6af162314728d13dfa87b6b3c795a3807032a0df25a0ce6c7ad9c24ab5c12a SHA512 9716ec45ba29cab6603896f717a6b21111ebacb48744009c8c032d6fd8dbb8f7444f27bc9f5c6f419a771544582ce5828e6b1870ea2cc37d917030c4c88de091 WHIRLPOOL 2061cf7dc15198bee8df0c3cd83b8810e60af4c6d33ad2e3bb5d119437a44c0c331ed7882a5d7ad5f5ec8cdc98a8eee0d19560c1f612a98ce56e728c0d755d7e
+DIST libsixel-1.7.3.tar.gz 4766335 SHA256 5a6e369b839e406a85cb54f2700e48d211a78618d7d4b6e3cd81d97dfda9ade9 SHA512 f7b6b9748389f140ce2f6cf0eeb74ab5063c21455c72013a7e066981439bb1ada7b3e9b68a7b3b57c49205271f32ffb8d6d002a4f2af45b1381dd015873b4e91 WHIRLPOOL 06afcdf0a92bf11fed829d42183dbcac5495b3bf162dacf87363c5f6e13214966a9af03419f8ad0ff63dfa9896158693d92811cbdee6a7217bf62190e5ea2bce
diff --git a/media-libs/libsixel/libsixel-1.7.3.ebuild b/media-libs/libsixel/libsixel-1.7.3.ebuild
new file mode 100644
index 000000000000..c9ebc20d9d26
--- /dev/null
+++ b/media-libs/libsixel/libsixel-1.7.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit bash-completion-r1
+
+DESCRIPTION="A lightweight, fast implementation of DEC SIXEL graphics codec"
+HOMEPAGE="https://github.com/saitoha/libsixel"
+SRC_URI="https://github.com/saitoha/libsixel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="curl gd gtk jpeg png"
+
+RDEPEND="curl? ( net-misc/curl )
+ gd? ( media-libs/gd )
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with curl libcurl) \
+ $(use_with gd) \
+ $(use_with gtk gdk-pixbuf2) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ --with-bashcompletiondir=$(get_bashcompdir) \
+ --disable-python
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+
+ cd images
+ docompress -x /usr/share/doc/${PF}/images
+ docinto images
+ dodoc egret.jpg map{8,16}.png snake.jpg vimperator3.png
+}