summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2017-10-26 15:28:06 +0900
committerBenda Xu <heroxbd@gentoo.org>2017-10-26 15:28:06 +0900
commit837d78b9630309b99c65ef0d191676e1ebd8476a (patch)
tree62ff301d3b80f7ce32b138984defb8492fc4e258
parentdev-perl/JSON-XS: Bump to version 3.40.0 (diff)
downloadgentoo-837d78b9630309b99c65ef0d191676e1ebd8476a.tar.gz
gentoo-837d78b9630309b99c65ef0d191676e1ebd8476a.tar.bz2
gentoo-837d78b9630309b99c65ef0d191676e1ebd8476a.zip
net-misc/unison: fix parallel build bug.
Reference: https://github.com/bcpierce00/unison/pull/100 Credit: Robert Forsman, Coacher, José María Fernández González Credit: Frank Steinmetzger, WGH Closes: https://bugs.gentoo.org/582666 Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--net-misc/unison/files/unison-2.48.4-Makefile-dep.patch20
-rw-r--r--net-misc/unison/unison-2.48.4.ebuild5
2 files changed, 25 insertions, 0 deletions
diff --git a/net-misc/unison/files/unison-2.48.4-Makefile-dep.patch b/net-misc/unison/files/unison-2.48.4-Makefile-dep.patch
new file mode 100644
index 000000000000..f65959dfb4ac
--- /dev/null
+++ b/net-misc/unison/files/unison-2.48.4-Makefile-dep.patch
@@ -0,0 +1,20 @@
+Makefile.OCaml: fswatch.cmi depends on ubase/prefs.cmi.
+
+ The dependency is needed to compile unison
+ in parallel.
+
+Reference: https://github.com/bcpierce00/unison/pull/100
+
+diff --git a/Makefile.OCaml b/Makefile.OCaml
+index 21610ce..84fe7ad 100644
+--- a/Makefile.OCaml
++++ b/Makefile.OCaml
+@@ -426,6 +426,8 @@ win32rc/unison.res.lib: win32rc/unison.res
+ @echo "$(CAMLC): $< ---> $@"
+ $(CAMLC) $(CAMLFLAGS) -c $(CWD)/$<
+
++fswatch.cmi : ubase/prefs.cmi
++
+ %.cmo: %.ml
+ @echo "$(OCAMLC): $< ---> $@"
+ $(OCAMLC) $(CAMLFLAGS) -c $(CWD)/$<
diff --git a/net-misc/unison/unison-2.48.4.ebuild b/net-misc/unison/unison-2.48.4.ebuild
index a1f428de517b..951e84771c95 100644
--- a/net-misc/unison/unison-2.48.4.ebuild
+++ b/net-misc/unison/unison-2.48.4.ebuild
@@ -30,6 +30,11 @@ SRC_URI="https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}
https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
S="${WORKDIR}"/src
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.48.4-Makefile-dep.patch
+ default
+}
+
src_compile() {
local myconf