summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-29 09:11:14 +0200
committerMichał Górny <mgorny@gentoo.org>2020-03-29 09:30:42 +0200
commit839f7153251f2aeb0a97db6d16b36b2b9eed35b2 (patch)
tree915652165b212e091437a799918ffe3798168f8b
parentdev-python/requests-toolbelt: Remove redundant versions (diff)
downloadgentoo-839f7153.tar.gz
gentoo-839f7153.tar.bz2
gentoo-839f7153.zip
dev-python/responses: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/responses/Manifest2
-rw-r--r--dev-python/responses/responses-0.6.0.ebuild30
-rw-r--r--dev-python/responses/responses-0.9.0.ebuild37
3 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/responses/Manifest b/dev-python/responses/Manifest
index e0495f58a736..6956b89d5820 100644
--- a/dev-python/responses/Manifest
+++ b/dev-python/responses/Manifest
@@ -1,3 +1 @@
DIST responses-0.10.7.tar.gz 22666 BLAKE2B 9f6d8ee0cc36ebb94bf6ac4284b474d30754af339f623a8a899061392321ba48a1f2d21593fb5bf2e6fac7c65ca6c252b6b7a1072e5548f91db489633aa3b686 SHA512 dcdbac1555090309b17eec1c02887eea5080321ff359afc42e6b558954caec2ab757e6009ae539e6e4d002cd06f2289d909a28ae583e6fa062a5df89c301e1ff
-DIST responses-0.6.0.tar.gz 14073 BLAKE2B 27d4a4a380a9154ded1030278213c0cd87308a488199c277050fa2a0a1dad87a61086094bc35279ff9c4201d06c59613bd1b0dbd18b4d83b8321341f6f1c4bb0 SHA512 32d41be5850f0040a4f2ad82a057d6ef73f0f83f7d3c250fa223d5614470b0b8b58790667af76ecc6b0b7e8e2a0a069c46c7913e983730c968c603e2716dec0b
-DIST responses-0.9.0.tar.gz 19766 BLAKE2B bd98c24d6458f33f7b8ad68edb3d0fc595a7d7b31889ff8270e1add13d537d80d67c3628ea6630674e8d49837f9d3933f680b366b4a7fab10048640a50129c48 SHA512 e5312587845cc9a3a938fa5d052ac1f04950d2eea5d83192c54affe079ee6593f3e249a24a8b43b1985c9fdc9131bfb477b93ca8a75d0386ed33cd56cc37d5ff
diff --git a/dev-python/responses/responses-0.6.0.ebuild b/dev-python/responses/responses-0.6.0.ebuild
deleted file mode 100644
index 6fe4e2b545f3..000000000000
--- a/dev-python/responses/responses-0.6.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python3_6)
-
-inherit distutils-r1
-
-DESCRIPTION="Utility for mocking out the Python Requests library"
-HOMEPAGE="https://github.com/getsentry/responses"
-SRC_URI="https://github.com/getsentry/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/requests-2.0[${PYTHON_USEDEP}]
- dev-python/cookies[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-DEPEND="test? ( ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- py.test || die
-}
diff --git a/dev-python/responses/responses-0.9.0.ebuild b/dev-python/responses/responses-0.9.0.ebuild
deleted file mode 100644
index 54e0807ea717..000000000000
--- a/dev-python/responses/responses-0.9.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Utility for mocking out the Python Requests library"
-HOMEPAGE="https://github.com/getsentry/responses"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/requests-2.0[${PYTHON_USEDEP}]
- dev-python/cookies[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- py.test || die "tests failed with ${EPYTHON}"
-}