summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-02-17 17:34:47 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-18 00:39:45 +0100
commit83a088ef3b1f8c5714e9b77adcb1b00a07790724 (patch)
tree09c44cef4b9805844a0b81fcf2df2b790e91d169
parentdev-ml/atd: bump to 2.11.0 (diff)
downloadgentoo-83a088ef3b1f8c5714e9b77adcb1b00a07790724.tar.gz
gentoo-83a088ef3b1f8c5714e9b77adcb1b00a07790724.tar.bz2
gentoo-83a088ef3b1f8c5714e9b77adcb1b00a07790724.zip
dev-cpp/curlpp: new package, add 0.8.1
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/29638 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-cpp/curlpp/Manifest1
-rw-r--r--dev-cpp/curlpp/curlpp-0.8.1.ebuild34
-rw-r--r--dev-cpp/curlpp/files/curlpp-0.8.1-fix-pkgconfig.patch39
-rw-r--r--dev-cpp/curlpp/metadata.xml24
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-cpp/curlpp/Manifest b/dev-cpp/curlpp/Manifest
new file mode 100644
index 000000000000..54731842449c
--- /dev/null
+++ b/dev-cpp/curlpp/Manifest
@@ -0,0 +1 @@
+DIST curlpp-0.8.1.tar.gz 143017 BLAKE2B 7f3911499b42077c9f108b0355005744300383836a1c82dcba80207482b231527482fb17dcd78a7f288903e996afaf49a4478c7cb5c821bf597b26f4450a430b SHA512 a46b47150c0f0f1f0056e08966ce2fefa5e86fc729406e0220fbcf400da5409f05c87b636b13da3c4d4460c1177aedb494b9569bbcd9012326d4d5f59376397e
diff --git a/dev-cpp/curlpp/curlpp-0.8.1.ebuild b/dev-cpp/curlpp/curlpp-0.8.1.ebuild
new file mode 100644
index 000000000000..8f19bb669879
--- /dev/null
+++ b/dev-cpp/curlpp/curlpp-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ wrapper for libcURL"
+HOMEPAGE="https://www.curlpp.org/"
+SRC_URI="https://github.com/jpbarrette/curlpp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}"
+
+DOCS=( Readme.md doc/AUTHORS doc/TODO )
+
+PATCHES=( "${FILESDIR}"/${P}-fix-pkgconfig.patch )
+
+src_install() {
+ use doc && DOCS+=( doc/guide.pdf )
+
+ cmake_src_install
+
+ rm "${ED}"/usr/$(get_libdir)/libcurlpp.a || die
+
+ if use examples ; then
+ dodoc -r examples/
+ fi
+}
diff --git a/dev-cpp/curlpp/files/curlpp-0.8.1-fix-pkgconfig.patch b/dev-cpp/curlpp/files/curlpp-0.8.1-fix-pkgconfig.patch
new file mode 100644
index 000000000000..701c81e9c43e
--- /dev/null
+++ b/dev-cpp/curlpp/files/curlpp-0.8.1-fix-pkgconfig.patch
@@ -0,0 +1,39 @@
+# upstream commit: <https://github.com/jpbarrette/curlpp/commit/5cdb4eb>
+
+From 5cdb4eb7ae898bc9b81cd1a7f87986827848456a Mon Sep 17 00:00:00 2001
+From: Dale Mellor <black-hole@rdmp.org>
+Date: Thu, 6 Jan 2022 18:57:23 +0000
+Subject: [PATCH] Put full paths in pkg-config specification.
+
+Currently, 'pkg-config --cflags curlpp' gives '-Iinclude', which is not good
+enough for outside projects to link to this package.
+
+* extras/curlpp.pc.in: use internal variables to make the generated
+ specifications more precise.
+---
+ extras/curlpp.pc.in | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/extras/curlpp.pc.in b/extras/curlpp.pc.in
+index b040ee0..e19c5b2 100644
+--- a/extras/curlpp.pc.in
++++ b/extras/curlpp.pc.in
+@@ -1,13 +1,13 @@
+ # This is a comment
+ prefix=@prefix@
+-exec_prefix=@prefix@
+-includedir=@includedir@
++exec_prefix=${prefix}
++includedir=${prefix}/@includedir@
++libdir=${exec_prefix}/@libdir@
+
+ Name: curlpp
+ Description: cURLpp is a libcurl C++ wrapper
+ Version: @VERSION@
+-Libs: -L@libdir@ -lcurlpp @LDFLAGS@ @LIBS@
+-Cflags: -I@includedir@ @CURLPP_CXXFLAGS@
++Libs: -L${libdir} -lcurlpp @LDFLAGS@ @LIBS@
++Cflags: -I${includedir} @CURLPP_CXXFLAGS@
+ # libcurl is required as non-private because CurlHandle.inl uses curl_easy_setopt.
+ Requires: libcurl
+-
diff --git a/dev-cpp/curlpp/metadata.xml b/dev-cpp/curlpp/metadata.xml
new file mode 100644
index 000000000000..045b624e941f
--- /dev/null
+++ b/dev-cpp/curlpp/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>gentoo@tastytea.de</email>
+ <name>tastytea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <name>Jean-Philippe Barrette-LaPierre</name>
+ </maintainer>
+ <doc>https://github.com/jpbarrette/curlpp/blob/master/doc/guide.pdf</doc>
+ <bugs-to>https://github.com/jpbarrette/curlpp/issues</bugs-to>
+ <remote-id type="github">jpbarrette/curlpp</remote-id>
+ </upstream>
+</pkgmetadata>