summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-27 18:43:10 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-27 20:09:07 +0100
commit83aa6cf6d4b98c21fed5de5d47b1f2ff5110bcb8 (patch)
treea3184a50eec00e7cbb8be5fbdbcb34cab649543d
parentdev-python/jinja: Stabilize 2.11.1 ALLARCHES (diff)
downloadgentoo-83aa6cf6d4b98c21fed5de5d47b1f2ff5110bcb8.tar.gz
gentoo-83aa6cf6d4b98c21fed5de5d47b1f2ff5110bcb8.tar.bz2
gentoo-83aa6cf6d4b98c21fed5de5d47b1f2ff5110bcb8.zip
dev-python/jinja: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jinja/Manifest1
-rw-r--r--dev-python/jinja/jinja-2.10.3-r1.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/dev-python/jinja/Manifest b/dev-python/jinja/Manifest
index b3faf4efa719..ca899e018f83 100644
--- a/dev-python/jinja/Manifest
+++ b/dev-python/jinja/Manifest
@@ -1,3 +1,2 @@
-DIST jinja-2.10.3.tar.gz 266316 BLAKE2B 0d8c10bb866eb887fd1c88ca5c5304f46d27930d8426587185ea72c0b79b512919bd5fa75987c26e433be049fd5764fb4ec08d42a4ec5ed00510fe8051e10f5e SHA512 566b781218b533c16b107b57e0252da5947fad262fd8d3fbb134b5916939c5e5d31c95e34bd6b14eec333d2ba3b4a6faa4168497a1ac774e7044f8220ac1b06e
DIST jinja-2.11.1.tar.gz 258637 BLAKE2B 80826397ada553b2bd1452f72430589ddebbd55aecffe6c6d9161ddcb46d9caa35635abd0946e063efda856391843831d25a7de91250d0f066b12cbf8b4af988 SHA512 66d9b7923f4b78133489bc28525d83032d37d5409ac572c00ea1aa342b3291bf0505c1e9d62f7a553553e26f06885e3d5c71bdcd2b334064b610692681694d33
DIST jinja-2.8.1.tar.gz 397144 BLAKE2B 78e4903da05ab3e8961b6bb6047116941b4bbf59d08b8283582972590409f98b5dc1f468a988525d96c552000279fcd0a31dae3ac1e5226f609a8854c8f9ca0b SHA512 f4655f1a43c06f7651fbd5251d0538788a3a6a3ffb93d9a8c239711cf043082c43d34706b6d71a18679d957faa6590e7e0259ffb8f7cc5e3300749526417a987
diff --git a/dev-python/jinja/jinja-2.10.3-r1.ebuild b/dev-python/jinja/jinja-2.10.3-r1.ebuild
deleted file mode 100644
index c5fe4cba443e..000000000000
--- a/dev-python/jinja/jinja-2.10.3-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="A full-featured template engine for Python"
-HOMEPAGE="http://jinja.pocoo.org/ https://pypi.org/project/Jinja2/"
-# pypi tarball is missing tests
-SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/markupsafe[${PYTHON_USEDEP}]
- !dev-python/jinja:compat"
-BDEPEND="${RDEPEND}"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-issues \
- dev-python/pallets-sphinx-themes
-distutils_enable_tests pytest
-
-# XXX: handle Babel better?
-
-wrap_opts() {
- local mydistutilsargs=()
-
- if [[ ${EPYTHON} == python* ]]; then
- mydistutilargs+=( --with-debugsupport )
- fi
-
- "${@}"
-}
-
-src_prepare() {
- # avoid unnecessary dep on extra sphinxcontrib modules
- sed -i '/sphinxcontrib.log_cabinet/ d' docs/conf.py || die
- printf "############################# SED ###############################\n"
-
- distutils-r1_src_prepare
-}
-
-python_prepare() {
- # async is not supported on python2
- if ! python_is_python3; then
- rm -f jinja2/async*.py || die "Failed to remove async from python2"
- fi
-}
-
-python_compile() {
- wrap_opts distutils-r1_python_compile
-}
-
-python_install_all() {
- if use examples ; then
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles/syntax
- doins ext/Vim/*
-}
-
-pkg_postinst() {
- if ! has_version dev-python/Babel; then
- elog "For i18n support, please emerge dev-python/Babel."
- fi
-}