summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-13 07:40:33 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-13 08:09:02 +0100
commit83be0beee0cb9f2fd1465ce34e83410b1dd3e1fd (patch)
treea4b1aa3502cd9b25cc161bcd01dc8163e638a143
parentdev-python/tavern: Bump to 2.0.0 (diff)
downloadgentoo-83be0beee0cb9f2fd1465ce34e83410b1dd3e1fd.tar.gz
gentoo-83be0beee0cb9f2fd1465ce34e83410b1dd3e1fd.tar.bz2
gentoo-83be0beee0cb9f2fd1465ce34e83410b1dd3e1fd.zip
dev-python/nbformat: Bump to 5.7.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbformat/Manifest1
-rw-r--r--dev-python/nbformat/nbformat-5.7.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index 879b40935401..d23f833c6415 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -1,3 +1,4 @@
DIST nbformat-5.4.0.gh.tar.gz 134574 BLAKE2B f61275ad501381f05dc22a79f24c175fa71610f09cf125a40aaa90d0e02d3b27d82d918c1036b0516d4f879609f65c1ce62de86b033012e25d353af453828b2e SHA512 f601438193bfcb11f1ceed74995ab6862ff8c916f9bddabe38fd70bb997f4407bede4318ae7034d75424b20b75846010ddda2a45b8fe8de6dd9310617b00fb9d
DIST nbformat-5.7.1.tar.gz 139291 BLAKE2B 680952ef35235021b36357babd98c94656d96888e1e5e01ecf35ce3233d51f751a60c964f0675fbad18242db8a1adb9fce2bbc512cefc4e30c254492584956c3 SHA512 248640ee23aae83c9c2b18502369d99c317447d40e5b3dc790260d21eda8ef027a7eca9ded34b98c7b17be7fe4b4401c556dbb9d4b0be80d4e4bff10a17381ce
DIST nbformat-5.7.2.tar.gz 140294 BLAKE2B 593f1b87d1fb58e47e07d94547145b2561689ab1463aa6fa1cd9178f09f09b4a10364caff9db0e8a1921903788fa94eab811d67ca8349cf87c151c946848c8e9 SHA512 5d4425d18c2f0f2cb1141f957bef93e6ea5be56fc57b73eb96427a5a1ccbb1f3a9730a70aa60448e20328401ed3afde21f55caa2241e8fd5eddd305a5a86c637
+DIST nbformat-5.7.3.tar.gz 140407 BLAKE2B 7e699939e0d13394851d6bccd02855beca041192ffc273c754770fe6c7d6135a17b32b40224d664bbfbc02e30dbb92aacb24b56cfd44a6c10b4c817a09bd11c1 SHA512 d705d959ea4d5b5294f137dff6b2b60b936ad7d2ff4aa06030429e9ee1e55cc5c9ec7d0f2196a67b67080e79177a18085c6bf75b84ab8ac5606fabb53455e4c2
diff --git a/dev-python/nbformat/nbformat-5.7.3.ebuild b/dev-python/nbformat/nbformat-5.7.3.ebuild
new file mode 100644
index 000000000000..59fb97d534a0
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.7.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/nbformat/
+ https://pypi.org/project/nbformat/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/numpydoc
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/nbformat-5.7.1-no-node.patch"
+)
+
+EPYTEST_IGNORE=(
+ # requires pep440 package, which is not really relevant for us
+ tests/test_api.py
+)