summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-03 06:41:04 +0000
committerSam James <sam@gentoo.org>2022-01-03 07:41:20 +0000
commit83c7cf6db1a8db6ef050c0d31cd06e2c7d25d252 (patch)
tree445353a85189e7d4d0645d072b9d1ed96316df0b
parentnet-irc/unrealircd: add 5.2.3 (diff)
downloadgentoo-83c7cf6d.tar.gz
gentoo-83c7cf6d.tar.bz2
gentoo-83c7cf6d.zip
sys-fs/mdadm: various build fixes
- Fix udev automagic dependency (add USE=udev); - ... and fix building without udev too. - Add patch to fix static linking against udev (only option is sys-fs/eudev though, as we dropped static-libs from sys-fs/udev and sys-apps/systemd due to issues like this and upstream not supporting it). Thanks-to: Hank Leininger <hlein@korelogic.com> (static linking patch) Thanks-to: Krzysztof Olędzki <ole+gentoo@ans.pl> (udev report/fix) Closes: https://bugs.gentoo.org/830461 Closes: https://bugs.gentoo.org/830485 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-fs/mdadm/files/mdadm-4.2-in_initrd-collision.patch36
-rw-r--r--sys-fs/mdadm/mdadm-4.2-r1.ebuild105
2 files changed, 141 insertions, 0 deletions
diff --git a/sys-fs/mdadm/files/mdadm-4.2-in_initrd-collision.patch b/sys-fs/mdadm/files/mdadm-4.2-in_initrd-collision.patch
new file mode 100644
index 000000000000..689e7d698788
--- /dev/null
+++ b/sys-fs/mdadm/files/mdadm-4.2-in_initrd-collision.patch
@@ -0,0 +1,36 @@
+Fix collision with libudev symbols when statically linking.
+
+https://bugs.gentoo.org/830485
+--- a/mdadm.h
++++ b/mdadm.h
+@@ -1665,7 +1665,7 @@
+ extern void udev_block(char *devnm);
+ extern void udev_unblock(void);
+
+-extern int in_initrd(void);
++extern int mdadm_in_initrd(void);
+
+ struct cmap_hooks {
+ void *cmap_handle; /* corosync lib related */
+--- a/mdmon.c
++++ b/mdmon.c
+@@ -309,7 +309,7 @@
+ {NULL, 0, NULL, 0}
+ };
+
+- if (in_initrd()) {
++ if (mdadm_in_initrd()) {
+ /*
+ * set first char of argv[0] to @. This is used by
+ * systemd to signal that the task was launched from
+--- a/util.c
++++ b/util.c
+@@ -2219,7 +2219,7 @@
+ return 0;
+ }
+
+-int in_initrd(void)
++int mdadm_in_initrd(void)
+ {
+ /* This is based on similar function in systemd. */
+ struct statfs s;
diff --git a/sys-fs/mdadm/mdadm-4.2-r1.ebuild b/sys-fs/mdadm/mdadm-4.2-r1.ebuild
new file mode 100644
index 000000000000..0a79356c4210
--- /dev/null
+++ b/sys-fs/mdadm/mdadm-4.2-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic systemd toolchain-funcs udev
+
+DESCRIPTION="Tool for running RAID systems - replacement for the raidtools"
+HOMEPAGE="https://git.kernel.org/pub/scm/utils/mdadm/mdadm.git/"
+DEB_PF="4.2~rc2-7"
+SRC_URI="https://www.kernel.org/pub/linux/utils/raid/mdadm/${P/_/-}.tar.xz
+ mirror://debian/pool/main/m/mdadm/${PN}_${DEB_PF}.debian.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+[[ "${PV}" = *_rc* ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="static +udev"
+
+BDEPEND="app-arch/xz-utils
+ virtual/pkgconfig"
+DEPEND="udev? (
+ static? ( sys-fs/eudev[static-libs] )
+ !static? ( virtual/libudev:= )
+ )"
+RDEPEND=">=sys-apps/util-linux-2.16
+ udev? ( !static? ( virtual/libudev:= ) )"
+DEPEND="${RDEPEND}"
+
+# The tests edit values in /proc and run tests on software raid devices.
+# Thus, they shouldn't be run on systems with active software RAID devices.
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-3.4-sysmacros.patch #580188
+ "${FILESDIR}/${PN}"-4.2-in_initrd-collision.patch #830461
+)
+
+mdadm_emake() {
+ # We should probably make corosync & libdlm into USE flags. #573782
+ local args=(
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ CC="$(tc-getCC)"
+ CWFLAGS="-Wall"
+ CXFLAGS="${CFLAGS}"
+ UDEVDIR="$(get_udevdir)"
+ SYSTEMD_DIR="$(systemd_get_systemunitdir)"
+ COROSYNC="-DNO_COROSYNC"
+ DLM="-DNO_DLM"
+
+ # https://bugs.gentoo.org/732276
+ STRIP=
+
+ "$@"
+ )
+ emake "${args[@]}"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ # CPPFLAGS won't work for this
+ use udev || append-cflags -DNO_LIBUDEV
+
+ mdadm_emake all
+}
+
+src_test() {
+ mdadm_emake test
+
+ sh ./test || die
+}
+
+src_install() {
+ mdadm_emake DESTDIR="${D}" install install-systemd
+ dodoc ChangeLog INSTALL TODO README* ANNOUNCE-*
+
+ insinto /etc
+ newins mdadm.conf-example mdadm.conf
+ newinitd "${FILESDIR}"/mdadm.rc mdadm
+ newconfd "${FILESDIR}"/mdadm.confd mdadm
+ newinitd "${FILESDIR}"/mdraid.rc mdraid
+ newconfd "${FILESDIR}"/mdraid.confd mdraid
+
+ # From the Debian patchset
+ into /usr
+ dodoc "${WORKDIR}"/debian/README.checkarray
+ dosbin "${WORKDIR}"/debian/checkarray
+ insinto /etc/default
+ newins "${FILESDIR}"/etc-default-mdadm mdadm
+
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}"/mdadm.weekly mdadm
+}
+
+pkg_postinst() {
+ if ! systemd_is_booted; then
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ # Only inform people the first time they install.
+ elog "If you're not relying on kernel auto-detect of your RAID"
+ elog "devices, you need to add 'mdraid' to your 'boot' runlevel:"
+ elog " rc-update add mdraid boot"
+ fi
+ fi
+}