summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-11-08 15:42:18 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-11-08 15:43:11 +0100
commit83ec2a3634e7a3a81605daa72541a842a47f9db2 (patch)
treea3a70d74af84ff1c108093c1ac6a05ce97a790a9
parentsys-apps/util-linux: Bump to version 2.33. Removed old. (diff)
downloadgentoo-83ec2a3634e7a3a81605daa72541a842a47f9db2.tar.gz
gentoo-83ec2a3634e7a3a81605daa72541a842a47f9db2.tar.bz2
gentoo-83ec2a3634e7a3a81605daa72541a842a47f9db2.zip
dev-libs/libinput: Bump to version 1.12.3
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.12.3.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 11d77e5beaaf..259d4c8253ca 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -2,3 +2,4 @@ DIST libinput-1.10.7.tar.xz 494648 BLAKE2B ddcbe5f54b90f8291c16e5912fa3d673fb2c6
DIST libinput-1.11.3.tar.xz 487408 BLAKE2B 38dc14cf018ca59279e8b6e85fd91f4b29545b4a55ab968cb11d9a8afc8d80c311efc6e57339b9baa9fb270f52cfb0758ff8ea313991867c35f3da47910977ac SHA512 5e18daab6202bcbfddeebc35dac4cabb5f726b5b73f5fc87975b58f3019a54a4b1f506a3200e920638ddddfb978a0b96c23c2e90b081942f86d33c16d4836949
DIST libinput-1.12.1.tar.xz 520072 BLAKE2B 2d2b2d82f27ac01ff25b3bf6fd7b77ca56467ab818cdc5d4a641629fed623ef5042915889f54f71b1881595af1d85770bbf4ecfd798c079878efa0a0546c4a36 SHA512 de1714526ee1244e3086729efa5b72724b2b989fa8d04418e633d1ef5a8ea777ae3cd4b8c5b015ca0da2b8cf5b07111bff2283c7d6068abcdfa81c3f71b81d68
DIST libinput-1.12.2.tar.xz 517712 BLAKE2B 3a8b1e5120334d44dcd14461fef4d20d51ec2f910c95bf10e54201dcd8b6ef2913a284940f05f0088ed810c0841b7e3cbfd1b33d7bcce3a81031330cb42bfe18 SHA512 f7122a1d18dd2d0072a34fd9897ebe25a065100b3754052d7ec133bddb56d5c2a5a94950cfc8366ef5d117180c28b3ff99b1a62f3ab95df5ac22f86721fbdc67
+DIST libinput-1.12.3.tar.xz 519496 BLAKE2B 15cd2aa14b6ad754534bceb6b99e05fc911666493f38e1c92097f5e08a06b751a17a4b0546176d5450ca8fde205bcb0dc5d7eaffe41739ae1bc6527205d8349b SHA512 cdc512cb53442ae85d5a23e10db9dd3548bcca0de24d7fcc48954a60773563d84d9b10278b6a693ade95d0789bb5d42bbb8b7cf1c178fe85401cb09a5402ff02
diff --git a/dev-libs/libinput/libinput-1.12.3.ebuild b/dev-libs/libinput/libinput-1.12.3.ebuild
new file mode 100644
index 000000000000..20a7cf9b8399
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.12.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit meson python-any-r1 udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc input_devices_wacom"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev:=
+ virtual/udev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ $(python_gen_any_dep '
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+python_check_deps() {
+ has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ $(meson_use doc documentation)
+ $(meson_use input_devices_wacom libwacom)
+ -Dtests=false # tests are restricted
+ -Dudev-dir="$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/Documentation/.
+ fi
+}
+
+pkg_postinst() {
+ udevadm hwdb --update --root="${ROOT%/}"
+}