summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-03-01 21:33:08 +0800
committerYixun Lan <dlan@gentoo.org>2024-03-08 09:06:19 +0000
commit83f119ed02ae5d6ed1b354af7ea0989a0d0053c9 (patch)
tree05eb7d2f3df1e08a07850717f9818cffcfe58dd2
parentapp-i18n/fcitx: add 5.1.8 (diff)
downloadgentoo-83f119ed02ae5d6ed1b354af7ea0989a0d0053c9.tar.gz
gentoo-83f119ed02ae5d6ed1b354af7ea0989a0d0053c9.tar.bz2
gentoo-83f119ed02ae5d6ed1b354af7ea0989a0d0053c9.zip
app-i18n/fcitx-gtk: add 5.1.2
Upstream fixed it in the new version. Closes: https://bugs.gentoo.org/925920 Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--app-i18n/fcitx-gtk/Manifest1
-rw-r--r--app-i18n/fcitx-gtk/fcitx-gtk-5.1.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-i18n/fcitx-gtk/Manifest b/app-i18n/fcitx-gtk/Manifest
index c81c7c371ad2..c436532992df 100644
--- a/app-i18n/fcitx-gtk/Manifest
+++ b/app-i18n/fcitx-gtk/Manifest
@@ -1 +1,2 @@
DIST fcitx-gtk-5.1.1.tar.xz 53716 BLAKE2B 6231d3b0c2fd788f0f780aee41837b9d8fb21f730b271082d8517f6f0da7e0a0d5216fd6364998bfe535872cf334b63fb1b326167175657d2c5cb59bac4aae45 SHA512 14dc84661e33435df5157127b2a4a81adc399cdc833e1c32795783d60bf10fd301fb658fc48673cad87abccfe3bccbb7b4ee0d0da74460b7ef1d6529a554a3eb
+DIST fcitx-gtk-5.1.2.tar.xz 53760 BLAKE2B 25eb0151bbc5a1277a593c2b07dce21f97f29d7d1bf4846a0edff7de0798e5bc33592ee00ddfffa8183a0e8d0bf1aaf1217b9f7e6cfde70c33b456740661e8bc SHA512 585a64b81caef55391e352a5efc2efcded1220c8be378be93e4fc6abc6b70132b3bb3211271d5ed02b1623a6ffcf7ce784de026969025b5efb3497f82676fefa
diff --git a/app-i18n/fcitx-gtk/fcitx-gtk-5.1.2.ebuild b/app-i18n/fcitx-gtk/fcitx-gtk-5.1.2.ebuild
new file mode 100644
index 000000000000..22819d3b08b2
--- /dev/null
+++ b/app-i18n/fcitx-gtk/fcitx-gtk-5.1.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-gtk"
+
+inherit cmake gnome2-utils xdg
+
+DESCRIPTION="Gtk im module for fcitx5 and glib based dbus client library"
+HOMEPAGE="https://github.com/fcitx/fcitx5-gtk"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="gtk2 +gtk3 +gtk4 +introspection +snooper onlyplugin wayland +X"
+REQUIRED_USE="|| ( gtk2 gtk3 gtk4 )"
+
+RDEPEND="
+ app-i18n/fcitx:5
+ >=dev-libs/glib-2.56
+ x11-libs/libxkbcommon
+ gtk2? ( x11-libs/gtk+:2 )
+ gtk3? ( x11-libs/gtk+:3[wayland?,X?] )
+ gtk4? ( gui-libs/gtk:4[wayland?,X?] )
+ introspection? ( dev-libs/gobject-introspection )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ kde-frameworks/extra-cmake-modules:0
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GTK2_IM_MODULE=$(usex gtk2)
+ -DENABLE_GTK3_IM_MODULE=$(usex gtk3)
+ -DENABLE_GTK4_IM_MODULE=$(usex gtk4)
+ -DENABLE_SNOOPER=$(usex snooper)
+ -DENABLE_GIR=$(usex introspection)
+ -DBUILD_ONLY_PLUGIN=$(usex onlyplugin)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ use gtk2 && gnome2_query_immodules_gtk2
+ use gtk3 && gnome2_query_immodules_gtk3
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ use gtk2 && gnome2_query_immodules_gtk2
+ use gtk3 && gnome2_query_immodules_gtk3
+}