summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-29 22:02:17 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-29 22:18:16 +0200
commit8405529f11b667257029a9bc8b0d65ee53871e23 (patch)
treeb4c0b58c9c9d515ce86d73d194cccd30e3778925
parentdev-python/sphobjinv: add 2.3.1 (diff)
downloadgentoo-8405529f.tar.gz
gentoo-8405529f.tar.bz2
gentoo-8405529f.zip
dev-python/asttokens: add 2.2.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/asttokens/Manifest1
-rw-r--r--dev-python/asttokens/asttokens-2.2.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/asttokens/Manifest b/dev-python/asttokens/Manifest
index c25b8ebb726a..02b1a88d2e8b 100644
--- a/dev-python/asttokens/Manifest
+++ b/dev-python/asttokens/Manifest
@@ -1,2 +1,3 @@
DIST asttokens-2.0.8.gh.tar.gz 50804 BLAKE2B 31b5fcf6c8c201279924da9297f16a1de087fe98e930dde341b54b29a54a23a462d44e1b2cc1c4695e7829b0dbb86c5a275ffac7c8430c191fd268026306c912 SHA512 e920aa50ba7f073f198182c053729e43c7cf3812a925cead258708ba88b82f6a7a32499810e67f346db79579607c07f211d924dc9e33b8bfdf44e5c9f171d53c
DIST asttokens-2.1.0.gh.tar.gz 55584 BLAKE2B eb2a73a47fcbfe1b75e0058f7fcc650ebc3cac00e1f816d2b5b7d02b75aaa07445de854c624e3564455036e2d973bc841e9ad3c18232d88b9091cfc3a2f95c71 SHA512 f89fe2ef700c3c07f48a87e39805792d00abc1050e619a987b863f4befc186505749bde956a95eaf152c4d69e087e32f8fa997cfa5527bbeb87e0143da89a662
+DIST asttokens-2.2.0.gh.tar.gz 55963 BLAKE2B 93bdaf42fc19b0735f4f9c70f20a250d8ac6e99e0d663222133be7c2d306b242c807b0a108e9e6dc6a3b014d19c34c4319de5d4c884113dbeacd0219fc780c87 SHA512 1a803bb99852c0dd186a4afc340c3543e8400efea03dc06331d761f8c70e97711915aaa5ae32aea54bd61fb0d77827c5ab3afaa7762913175a5ad75ca2fff5ca
diff --git a/dev-python/asttokens/asttokens-2.2.0.ebuild b/dev-python/asttokens/asttokens-2.2.0.ebuild
new file mode 100644
index 000000000000..839fb416705f
--- /dev/null
+++ b/dev-python/asttokens/asttokens-2.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Annotate Python AST trees with source text and token information"
+HOMEPAGE="
+ https://github.com/gristlabs/asttokens/
+ https://pypi.org/project/asttokens/
+"
+SRC_URI="
+ https://github.com/gristlabs/asttokens/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/astroid[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # test suite itself broken with new astroid versions, upstream less care
+ # https://github.com/gristlabs/asttokens/issues/79
+ tests/test_astroid.py
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}