summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-06 15:04:13 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-06 15:44:05 +0200
commit8407588980825cf925ad4bc675fa14079e3cc435 (patch)
tree335b8a56aaedf592adaeff90b2e6e9d82156b5d2
parentsys-libs/libomp: Add 19.0.0_pre20240404 snapshot (diff)
downloadgentoo-84075889.tar.gz
gentoo-84075889.tar.bz2
gentoo-84075889.zip
sys-devel/clang-runtime: Add 19.0.0_pre20240404 snapshot
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/clang-runtime/clang-runtime-19.0.0_pre20240404.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-19.0.0_pre20240404.ebuild b/sys-devel/clang-runtime/clang-runtime-19.0.0_pre20240404.ebuild
new file mode 100644
index 000000000000..323c0b62c062
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-19.0.0_pre20240404.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="${PV%%.*}"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-16,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}