summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-20 16:21:39 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-20 16:29:09 +0100
commit8427df199105f9df20317d9b0809d5ffdb7c38b4 (patch)
tree4bc8efe1d435312f3c5cd4886c07c533197c7477
parentx11-plugins/wmcalc: Stabilize 0.7 amd64, #920382 (diff)
downloadgentoo-8427df199105f9df20317d9b0809d5ffdb7c38b4.tar.gz
gentoo-8427df199105f9df20317d9b0809d5ffdb7c38b4.tar.bz2
gentoo-8427df199105f9df20317d9b0809d5ffdb7c38b4.zip
dev-python/dogpile-cache: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dogpile-cache/Manifest1
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-1.3.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/dogpile-cache/Manifest b/dev-python/dogpile-cache/Manifest
index 8581689ab24a..0c3fd2fe84f0 100644
--- a/dev-python/dogpile-cache/Manifest
+++ b/dev-python/dogpile-cache/Manifest
@@ -1 +1,2 @@
DIST dogpile.cache-1.2.2.tar.gz 263102 BLAKE2B ccd64492e154f30b27a9b031086acd89002c9cae402105720022370688c6343c6c7a023fc643390764a40dfa9dde083e5adaf644aa79939c0bf6573c4c518366 SHA512 23b078b79e4b1f87c8d397d35b772f0b5fee66a0e452de06e7644ecb1ef577ae1629307a0e32fa62f49d536f95fb62fe70ededeb43647fa0c2e0baf896261931
+DIST dogpile.cache-1.3.0.tar.gz 265984 BLAKE2B 80aba607dad31b1ddb4e8b706f40c2ed47c7c2a4f074b7d115737ed934ed2b97c900e8ff5f01fa52c3177ebd364d4bac585cca4dd1d6aa5830cf42cdade52070 SHA512 fb00e114b2107d4ee27d699c62581554758f9ff2121ccade8f5c5aee5240adc0c6a1ae734f5d64b06f25493bfe19c40cffe1393d361be484433baaec74791b5a
diff --git a/dev-python/dogpile-cache/dogpile-cache-1.3.0.ebuild b/dev-python/dogpile-cache/dogpile-cache-1.3.0.ebuild
new file mode 100644
index 000000000000..24f2c8fe8b23
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-1.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value"
+HOMEPAGE="
+ https://github.com/sqlalchemy/dogpile.cache/
+ https://pypi.org/project/dogpile.cache/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/decorator-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest