summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2022-03-03 21:42:14 +0900
committerAkinori Hattori <hattya@gentoo.org>2022-03-03 21:42:14 +0900
commit8429189d8d10bb0e9346314e3408b8f8a78481b3 (patch)
treef591bf9013faa15843ef477d9c234ccde9d95714
parentdev-scheme/gauche-gtk: new upstream release (diff)
downloadgentoo-8429189d8d10bb0e9346314e3408b8f8a78481b3.tar.gz
gentoo-8429189d8d10bb0e9346314e3408b8f8a78481b3.tar.bz2
gentoo-8429189d8d10bb0e9346314e3408b8f8a78481b3.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.15.22.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 86799df800d5..00d3eca81ee3 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.15.11.tar.gz 10250973 BLAKE2B 1285d34535fc7087d19c1e01f70ace3aacc4a45ae04d7ab32c2af7b61eab7b547fa901ee01ddd1b1356de7fcb1f30d8c0dce58692b8b9448442eb5bdcdd9f7bd SHA512 38e74e6b95bff13f7b166158c145aa9d2180ba70380dad428fce322535b959cd3b8980ed499c2aec4a9701f1398b4ce793b99ce0af30c1eb2ce015bd35b990a7
DIST ibus-typing-booster-2.15.16.tar.gz 10279700 BLAKE2B 75f9ea696ec5320e56ce06926c7fec56ea5918e90ac2abe416a6161e358564c2851588487672b711a28a6a770372300a90b3717fe3a8d51b118a937136cff7e5 SHA512 5a2f315f3def693508f25dbc0fbda8b7a8d6b260e9a676cd38b720e059e3600a6abebc8f06581fe6e96e7f825eb3401235ebfa5a5ff491b39d5804469b2d2fa0
+DIST ibus-typing-booster-2.15.22.tar.gz 10779889 BLAKE2B c35306fd3556178257047573f58658ea44d1ceee341964bee5719f5e4509f385e6b1ca520324c66bc417a74d89e5b3eebc7a7413ce2e60398bc83f992eb8a07e SHA512 ae7683434111c7c267c1eb05e88609e0895308443a0510e9eba67000681bb3dfddcf5a652f33bd4b63c7aed10fe2109eafcaae19a4052ae008e92ab9314ae907
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.15.22.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.15.22.ebuild
new file mode 100644
index 000000000000..58166b805e3c
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.15.22.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}