summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-02-24 09:06:56 +0100
committerHans de Graaff <graaff@gentoo.org>2023-02-25 08:20:50 +0100
commit8435473a510696ee7c2019e88b9e84c775cfc54c (patch)
tree4471a189de81e7f2aface38dc2e0938fc1f9b312
parentsys-process/iotop-c: Stabilize 1.23 arm, #896392 (diff)
downloadgentoo-8435473a510696ee7c2019e88b9e84c775cfc54c.tar.gz
gentoo-8435473a510696ee7c2019e88b9e84c775cfc54c.tar.bz2
gentoo-8435473a510696ee7c2019e88b9e84c775cfc54c.zip
dev-ruby/plist: add 3.7.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/plist/Manifest1
-rw-r--r--dev-ruby/plist/plist-3.7.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/plist/Manifest b/dev-ruby/plist/Manifest
index 26f4a805b58e..014d14ef74d2 100644
--- a/dev-ruby/plist/Manifest
+++ b/dev-ruby/plist/Manifest
@@ -1 +1,2 @@
DIST plist-3.6.0.tar.gz 37311 BLAKE2B dd9bd1a7cf62974fb4b51744ab826ab65e6e02030073ec3b60b3d420982b65ceb3b1c1bb50e0f38fb68e25c366b17e7885cf5053418338ea05c324afad2df5b7 SHA512 d5991d944d8f02cacecdbdf9834379f34fd915eb3cf252aa1923e8d49a3b17c72ae07fbd53f1cfe9d0c14147729f4736838e4cea3fc286a90280bcc3de4b7fd1
+DIST plist-3.7.0.tar.gz 38215 BLAKE2B a92cb0e4902c4e7a76ab9aca32a340c69f196bfb2c8836deab897e7cf9b653e74bae1aa0ad4de0eee71876bcc787bbc7caaa0ba61d4a716bff3cf202d14a6a12 SHA512 138ff5d9890f3da2add2f2d7935d7cacfcd57314ae92bf04b1ca4d37fe00d586a40629e84c8b9ef871db277587efe2375d934ca5a7e7b92eaffb441ee361e533
diff --git a/dev-ruby/plist/plist-3.7.0.ebuild b/dev-ruby/plist/plist-3.7.0.ebuild
new file mode 100644
index 000000000000..7c16e0721bea
--- /dev/null
+++ b/dev-ruby/plist/plist-3.7.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to manipulate Property List files, also known as plists"
+HOMEPAGE="https://github.com/patsplat/plist"
+SRC_URI="https://github.com/patsplat/plist/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}