summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-05 22:37:57 -0500
committerSam James <sam@gentoo.org>2024-03-06 05:29:50 +0000
commit845cbe2fef97ec5d8f0cb983ff075d2be9d72537 (patch)
tree819fdeebc41b399c9a7647a36f77c5bedd07f5f5
parentdev-util/wachy: modernise cargo.eclass usage (diff)
downloadgentoo-845cbe2fef97ec5d8f0cb983ff075d2be9d72537.tar.gz
gentoo-845cbe2fef97ec5d8f0cb983ff075d2be9d72537.tar.bz2
gentoo-845cbe2fef97ec5d8f0cb983ff075d2be9d72537.zip
sci-libs/arpack: mark as LTO-unsafe
It fails in tests, but unfortunately that means we cannot... test... compiling with LTO. Closes: https://bugs.gentoo.org/878139 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/arpack/arpack-3.9.1.ebuild11
-rw-r--r--sci-libs/arpack/arpack-9999.ebuild11
2 files changed, 18 insertions, 4 deletions
diff --git a/sci-libs/arpack/arpack-3.9.1.ebuild b/sci-libs/arpack/arpack-3.9.1.ebuild
index c3a10d3e5d15..fe8ac4dd7b91 100644
--- a/sci-libs/arpack/arpack-3.9.1.ebuild
+++ b/sci-libs/arpack/arpack-3.9.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools fortran-2 toolchain-funcs
+inherit autotools flag-o-matic fortran-2 toolchain-funcs
DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ https://github.com/opencollab/arpack-ng"
@@ -39,6 +39,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/878139
+ # https://github.com/opencollab/arpack-ng/issues/451
+ #
+ # Only when building tests. Still this means we cannot test it.
+ filter-lto
+
econf \
--disable-static \
--enable-icb \
diff --git a/sci-libs/arpack/arpack-9999.ebuild b/sci-libs/arpack/arpack-9999.ebuild
index 0388be81f2bc..97ecc817d3fc 100644
--- a/sci-libs/arpack/arpack-9999.ebuild
+++ b/sci-libs/arpack/arpack-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools fortran-2 toolchain-funcs
+inherit autotools flag-o-matic fortran-2 toolchain-funcs
DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ https://github.com/opencollab/arpack-ng"
@@ -35,6 +35,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/878139
+ # https://github.com/opencollab/arpack-ng/issues/451
+ #
+ # Only when building tests. Still this means we cannot test it.
+ filter-lto
+
econf \
--disable-static \
--enable-icb \