summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-04-02 11:39:51 +0200
committerHans de Graaff <graaff@gentoo.org>2021-04-02 13:15:58 +0200
commit849d7e680c5047eb9c0fa8f3630d9bea1db860fe (patch)
tree8f37935875a7e95bdc570694b76d36a64c46ad51
parentdev-ruby/method_source: add ruby30 (diff)
downloadgentoo-849d7e68.tar.gz
gentoo-849d7e68.tar.bz2
gentoo-849d7e68.zip
dev-ruby/thread_safe: add ruby30
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/thread_safe/thread_safe-0.3.6-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/thread_safe/thread_safe-0.3.6-r1.ebuild b/dev-ruby/thread_safe/thread_safe-0.3.6-r1.ebuild
new file mode 100644
index 000000000000..180c2937a11e
--- /dev/null
+++ b/dev-ruby/thread_safe/thread_safe-0.3.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of thread-safe versions of common core Ruby classes"
+HOMEPAGE="https://github.com/ruby-concurrency/thread_safe"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Higher atomic dependency since earlier versions crash on ruby20 while
+# running thread_safe tests.
+ruby_add_bdepend "test? ( >=dev-ruby/atomic-1.1.16 )"
+
+each_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e '/coveralls/I s:^:#:' \
+ -e '/simplecov/ s:^:#:' \
+ -e '/SimpleCov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ einfo "The test suite may take up to 10 minutes to run without apparent feedback"
+ each_fakegem_test
+}