summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-01 08:33:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-01 09:44:55 +0200
commit84b64f4c3f9874929676a1828898e841bebdf296 (patch)
treefaef144d4c47e6c35b00916f0269673c70a2c27f
parentdev-python/iminuit: Bump to 2.5.0 (diff)
downloadgentoo-84b64f4c.tar.gz
gentoo-84b64f4c.tar.bz2
gentoo-84b64f4c.zip
dev-python/python-slugify: Bump to 5.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-slugify/Manifest1
-rw-r--r--dev-python/python-slugify/python-slugify-5.0.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index e86b4047421d..b6269765eb97 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1,2 +1,3 @@
DIST python-slugify-1.2.6.tar.gz 8439 BLAKE2B 74699bf80408e1b6a705525b0ada2612cc6224a2ac1e17ce21230ed684af144c0f72ad99b32674bf19bd716d2cfc3a2f0da6f74facc99acba16e3ebc1873f3f3 SHA512 ad45958d03892d8db75967b150f25509c05ab2a87d5ac4a2ed12fccccfe1f86d7db26c406c6de22ba759b77fe772cc0c00d0e517c71db085618f62094ddadfd2
DIST python-slugify-4.0.1.tar.gz 11509 BLAKE2B b505c62c959dae3823db4441b8811ed98ec8afa0278325cb2715abb63a84b5de1506362699bc39216bbac4100ae265671f940dbbbdaf9164fd251bdaa7af462a SHA512 c1d99a9dc891c4cfa927e4d2bc5701f47b23b7882cce22350283a53c6ded18e1290196c3bb9838883c29c9cb3582e5e684edffd50dfbb4e9da9c2b821ea54bb5
+DIST python-slugify-5.0.0.tar.gz 11730 BLAKE2B 0ec93c230523bcd4ba5f917bc9d2676ae92fc164eccc84198777a59c36ff427fdb7a242bd89f9bc3d24e86b5a1d106f0118cf118349de648f5779c384445abab SHA512 b29c542ec3cb3d05d88be0fb53909b160022fe97dbc89efc0eef5f4e2414031026f570dd6eec1e7bbe2930d801c2fd8d152e49cd2639cddb23392c9b11e7266b
diff --git a/dev-python/python-slugify/python-slugify-5.0.0.ebuild b/dev-python/python-slugify/python-slugify-5.0.0.ebuild
new file mode 100644
index 000000000000..ae681ae6129d
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-5.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="https://github.com/un33k/python-slugify https://pypi.org/project/python-slugify/"
+SRC_URI="https://github.com/un33k/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/text-unidecode[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest