summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2021-06-01 00:45:47 -0400
committerSam James <sam@gentoo.org>2021-06-12 05:40:11 +0000
commit84c1c6ba650d5d79271c86a509633ce693b23686 (patch)
tree78a8b2dd74bb6e913ee5e33bbe0876ff1b6008e0
parentdev-python/xapp: update maintainers per conversation with laurantino (diff)
downloadgentoo-84c1c6ba.tar.gz
gentoo-84c1c6ba.tar.bz2
gentoo-84c1c6ba.zip
x11-libs/xapps: fix prefix install
PYTHON_GI_OVERRIDESDIR contains the fully qualified python path, so no need to prefix it with $ED. Closes: https://bugs.gentoo.org/793092 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Closes: https://github.com/gentoo/gentoo/pull/21079 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-libs/xapps/xapps-2.0.6.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/x11-libs/xapps/xapps-2.0.6.ebuild b/x11-libs/xapps/xapps-2.0.6.ebuild
index b62fa4e6f2cc..bade1ef0d30b 100644
--- a/x11-libs/xapps/xapps-2.0.6.ebuild
+++ b/x11-libs/xapps/xapps-2.0.6.ebuild
@@ -74,9 +74,9 @@ src_install() {
install_pygobject_override() {
PYTHON_GI_OVERRIDESDIR=$("${EPYTHON}" -c 'import gi;print(gi._overridesdir)' || die)
einfo "gobject overrides directory: ${PYTHON_GI_OVERRIDESDIR}"
- mkdir -p "${ED}/${PYTHON_GI_OVERRIDESDIR}/" || die
- cp -r "${D}"/pygobject/* "${ED}/${PYTHON_GI_OVERRIDESDIR}/" || die
- python_optimize "${ED}/${PYTHON_GI_OVERRIDESDIR}/"
+ mkdir -p "${D}/${PYTHON_GI_OVERRIDESDIR}/" || die
+ cp -r "${D}"/pygobject/* "${D}/${PYTHON_GI_OVERRIDESDIR}/" || die
+ python_optimize "${D}/${PYTHON_GI_OVERRIDESDIR}/"
}
python_foreach_impl install_pygobject_override
rm -r "${D}/pygobject" || die