summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-03 10:13:39 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-03 10:19:22 -0700
commit84e20be71210c47461e88bc549b5d799b8f47660 (patch)
treee70c4526bdc137984136533d9c8347d77594b559
parentmail-client/aerc: add 0.9.0 (diff)
downloadgentoo-84e20be7.tar.gz
gentoo-84e20be7.tar.bz2
gentoo-84e20be7.zip
x11-libs/libXcursor: Version bump to 1.2.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/libXcursor/Manifest1
-rw-r--r--x11-libs/libXcursor/libXcursor-1.2.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/x11-libs/libXcursor/Manifest b/x11-libs/libXcursor/Manifest
index b0d8cbfe67e6..8259e1d30626 100644
--- a/x11-libs/libXcursor/Manifest
+++ b/x11-libs/libXcursor/Manifest
@@ -1 +1,2 @@
DIST libXcursor-1.2.0.tar.bz2 334144 BLAKE2B d1dc7f09b88bc570653e615ec5e854b7cd9362a8429e90dc36e1d7efe26fd9c0eb9a38ae8d18a308e1912bb1765e2adbf13f36a265500be2f787d60017091898 SHA512 2b12d0fd17e311ce269dbba58588698885815eb07aa44d48525ed5cd9e5f379bb90138a792a191e2f74888ab10b3ca9a4f507f21de0984ed79748973ab927a03
+DIST libXcursor-1.2.1.tar.xz 280352 BLAKE2B 5c59a43d9cdaaab887ef7ffbe836534508e3542959dd5011c08e46db1d5e4de6e7ee47b1574eb1bd2aebc8baa8fe401e5195fa73bb2ab47b779dbd03af4bbf4a SHA512 ebb42a39855aab86d0c11fe6ad33d011cf56a6dc5c309bef643460319c03df239b7e09fe88777bb25c0e9ff8aceac6bf66e51cc04a2d5ee463b3bc3bbf1674e3
diff --git a/x11-libs/libXcursor/libXcursor-1.2.1.ebuild b/x11-libs/libXcursor/libXcursor-1.2.1.ebuild
new file mode 100644
index 000000000000..850a4cccca0a
--- /dev/null
+++ b/x11-libs/libXcursor/libXcursor-1.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+DESCRIPTION="X.Org Xcursor library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-icondir="${EPREFIX}"/usr/share/cursors/xorg-x11
+ --with-cursorpath='~/.cursors:~/.icons:/usr/local/share/cursors/xorg-x11:/usr/local/share/cursors:/usr/local/share/icons:/usr/local/share/pixmaps:/usr/share/cursors/xorg-x11:/usr/share/cursors:/usr/share/pixmaps/xorg-x11:/usr/share/icons:/usr/share/pixmaps'
+)