summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-12-30 20:41:49 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-12-30 20:42:01 +0100
commit84e2513907334678825e5b6230c57f820ba5ec1c (patch)
tree32478c9acea0d762717cda3c8952f136fed95cc2
parentdev-python/flask-htmlmin: Depend on setuptools (diff)
downloadgentoo-84e2513907334678825e5b6230c57f820ba5ec1c.tar.gz
gentoo-84e2513907334678825e5b6230c57f820ba5ec1c.tar.bz2
gentoo-84e2513907334678825e5b6230c57f820ba5ec1c.zip
dev-db/xtrabackup-bin: Bump to v2.4.9
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-db/xtrabackup-bin/Manifest2
-rw-r--r--dev-db/xtrabackup-bin/xtrabackup-bin-2.4.9.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-db/xtrabackup-bin/Manifest b/dev-db/xtrabackup-bin/Manifest
index 62dcfcc82203..ab45156b86cc 100644
--- a/dev-db/xtrabackup-bin/Manifest
+++ b/dev-db/xtrabackup-bin/Manifest
@@ -4,3 +4,5 @@ DIST percona-xtrabackup-2.4.6-Linux-i686.tar.gz 80985248 BLAKE2B 5c946c4986713e9
DIST percona-xtrabackup-2.4.6-Linux-x86_64.tar.gz 82382422 BLAKE2B 5dc098f30f9ed370a7b44ad2561fb9c5b75bdf7810908a350b936497465c536c3366ede7135afde1cacff6d25a79df7c8979c8667fe64d5af56edb00818552e1 SHA512 7299f7e47417e62fdad5fdfb0637d4ba7e94e0804207ad690cd8573fc83e5eea15d0c5504bc084f24cec074765f51fafdb780115bbd336dd7e36ad123fae218e
DIST percona-xtrabackup-2.4.8-Linux-i686.tar.gz 79705968 BLAKE2B e10625d8082cfc683151bf011df7050f4618038b4babbe660bb36068de99b7e8f5da73972e72801947fd805bc0e764e8a11be027de59cd4300671ee69291e112 SHA512 8c1025e56ec0d6d6e73cf13f22858a81ce5390a691d5bf1989b42162c0b93837f73616ead294c5f14838b461b5124d2d9cbb6650ab9b089f1820a327a7bc4341
DIST percona-xtrabackup-2.4.8-Linux-x86_64.tar.gz 81550220 BLAKE2B 7314b08deae3213c1e94404ace7c3f1397c948da1656ce623d31aa925c495d0dccff23f5102e111f336436452f18b5a3a64e56074beec396b43aef61373ab693 SHA512 e89d5cacb80022e1e427d0837137f14b9284e92277cde2f2365d1e4ede4d63d98c990dbc4ab65c8062f144d8a1644c2b9c9adebc220d6d251c9f00a2f2f53bfc
+DIST percona-xtrabackup-2.4.9-Linux-i686.tar.gz 79816483 BLAKE2B 0fd97ee14c97f66edf629fa0300bfa2d6b333ac5942f5cee46dd9d0ad04ef2fe12750209971ff8f6a8ca225a85deaa42ca64c484e12e60c85789153689e55c42 SHA512 014921b0ea9fec783adbdd4556301e8df77f801729faae5b2b7245c349df069fc3af33ebef5ec65ef0e020c7b0ec8ebf4aa7a7acc0e9936c6f4a90b721a5de19
+DIST percona-xtrabackup-2.4.9-Linux-x86_64.tar.gz 90282874 BLAKE2B 2c4cdb8c6da443baf01857fbe4b27be002df370b67687f417a9fde6b08a5e72482552b165a9f27fda305787b42089fb138a4fca2f1d683afbd42efa23746b13c SHA512 24138c098d8e674de291dc494c38f2fce52f4d6a5a2552a62b34ea801b867431917449656f990043c7bbbc1e18a8806c4343eadbe1fea17e36ff1b10109e5047
diff --git a/dev-db/xtrabackup-bin/xtrabackup-bin-2.4.9.ebuild b/dev-db/xtrabackup-bin/xtrabackup-bin-2.4.9.ebuild
new file mode 100644
index 000000000000..734bbe0fa11e
--- /dev/null
+++ b/dev-db/xtrabackup-bin/xtrabackup-bin-2.4.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+MY_PN="percona-${PN/-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="MySQL hot backup software. non-blocking backups for InnoDB/XtraDB databases"
+HOMEPAGE="https://www.percona.com/software/percona-xtrabackup"
+SRC_URI="
+ amd64? (
+ https://www.percona.com/downloads/XtraBackup/Percona-XtraBackup-${PV}/binary/tarball/${MY_P}-Linux-x86_64.tar.gz
+ )
+ x86? (
+ https://www.percona.com/downloads/XtraBackup/Percona-XtraBackup-${PV}/binary/tarball/${MY_P}-Linux-i686.tar.gz
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# NOTE: dev-perl/DBD-mysql still necessary, now for bin/xtrabackup?
+DEPEND=""
+RDEPEND="dev-libs/libaio
+ dev-libs/libgcrypt:11/11
+ dev-libs/libgpg-error
+ dev-perl/DBD-mysql
+ sys-libs/zlib"
+
+src_unpack() {
+ default
+
+ if use amd64; then
+ S="${WORKDIR}/${MY_P}-Linux-x86_64"
+ elif use x86; then
+ S="${WORKDIR}/${MY_P}-Linux-i686"
+ fi
+}
+
+src_install() {
+ # Two new tools with an old libcurl.so.3 dep...
+ # TODO: Wait for a new release using libcurl.so.4
+ # net-misc/curl dev-libs/libev
+ # dobin bin/xbcloud{,_osenv}
+
+ for tool in xbcrypt xbstream xtrabackup; do
+ dobin bin/${tool}
+ done
+
+ for man in innobackupex xbcrypt xbstream xtrabackup; do
+ doman man/man1/${man}.1
+ done
+
+ dosym xtrabackup /usr/bin/innobackupex
+}
+
+pkg_postinst() {
+ ewarn "innobackupex got deprecated in 2.3.x series and is just a symlink to xtrabackup"
+}