summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-25 06:09:35 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-25 06:14:33 +0100
commit8518353d37188f3debfbbe523222566bb9625a11 (patch)
tree391cc3846472a24130c16cb4d1382d03a0370b98
parentdev-python/icalendar: Bump to 5.0.3 (diff)
downloadgentoo-8518353d37188f3debfbbe523222566bb9625a11.tar.gz
gentoo-8518353d37188f3debfbbe523222566bb9625a11.tar.bz2
gentoo-8518353d37188f3debfbbe523222566bb9625a11.zip
dev-python/pyproject-fmt: Bump to 0.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyproject-fmt/Manifest1
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-0.4.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index 46f73c46a511..b51a9ac696f7 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -1,2 +1,3 @@
DIST pyproject-fmt-0.3.5.gh.tar.gz 14718 BLAKE2B 6ccf58350fd2c4cd0726a3f66513cf9f4558b9e1cc8b9b1e2ea2b94844b9e6ab925ff5f141cbd32d8ea63b43f84a432034af69150fc1fa8ddcbfeab0a139c2d5 SHA512 c6b668d860f04a944872867574cfbe0946e7a5425cfa5f5b18e9ef0ce1e007197e7eb9915d76ca54e8963e71eb3fa7aee1f8362a63aa7bf89e06ca95681cdae8
DIST pyproject-fmt-0.4.0.gh.tar.gz 14851 BLAKE2B 0ed9b7974410929b32ebfe0b452784cf150f58e531eb4cfd25359f3963dce326860ab2e3c01cd98911044dce9397327ea1fdcc4649133fac4fcf845d2fabf1ee SHA512 c5376abc29eac99df078c1981a01c3c7f12a55d0350df89deeb7f7ec74dad4470d7ff19e89fd399fd42150f93d214c9203b3e210a1facbf973a4ffbfc4241d8c
+DIST pyproject-fmt-0.4.1.gh.tar.gz 14853 BLAKE2B e06e3602290fdc4df00fb48dfe9d6d516a623ef29eaa535ab3b11754a577385611313172f207966b121f072a5b453774afcbf5e8699a0b7fd4426f5332e48e5a SHA512 f00999470e66e7f11e9299a902b686342fbad27a07634206011ff7712c7c422f9962d8a4eeffae6a6263712620b787bbdcd78c2129cb4b164631b56a45910363
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-0.4.1.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-0.4.1.ebuild
new file mode 100644
index 000000000000..1173c6f3deb3
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-0.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+SRC_URI="
+ https://github.com/tox-dev/pyproject-fmt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.8.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}