summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-28 06:35:17 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-28 07:31:43 +0200
commit85271c51a98870c7f76f5c963bed603f0e377139 (patch)
tree19deb4171700552816391255f5ac7a6a01038053
parentdev-java/asm-util: bump to 9.2 (diff)
downloadgentoo-85271c51.tar.gz
gentoo-85271c51.tar.bz2
gentoo-85271c51.zip
dev-python/botocore: Bump to 1.21.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.8.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 1c8400d35b61..8924afb62cb7 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -8,3 +8,4 @@ DIST botocore-1.21.4.tar.gz 7964960 BLAKE2B 71d55b47633aa658a9dc921375c77230a6eb
DIST botocore-1.21.5.tar.gz 7968981 BLAKE2B cea2c648e5f8d6f99bd1f11f430511abdc413bb3a2e36b2ca149f4edb0b8b750cba1149474351ab52a04e08018de81fab93607eb65e19b452a80a249cefb5871 SHA512 ad84b3f75883279452ba9922492e1a63b9f951ed54767feb573000d077335eb50685727ae1924d02f23d5342bcd8f96d2a56b06efedcded4b718e8ec68f6d636
DIST botocore-1.21.6.tar.gz 7974218 BLAKE2B f3391b620a21d04712e1254c4e8ffc090956bc1e0a41278be2c0e02a659ada639af2cc4e94bf607492164a8425988c16e8b899726fe645871b1cf6d1f98ef04d SHA512 1a74f2450a1c57a61c704550c0f08fd518b8d4fc463acdd8622ca8bf7fa51293c52c54999e1a1d563815cb0fd35585072753d623739a6738367b0bae94f655b7
DIST botocore-1.21.7.tar.gz 7977343 BLAKE2B 19c5bf5de40ab131585e30bb85486fcffc3428808811b312b33578174ce31a691f4f4d955462120f05d2aad2cd5e5772789704eee641760fb67099aa3cddc9b5 SHA512 db1bb36faa6857a1cc717e5d591954415bb948178ee2be90ab9c32c11b1fb45c5b5aff87dfacd907c2f11bc7cdd2cd4de2ee9c847fa8cda4e5f0814a828b1019
+DIST botocore-1.21.8.tar.gz 7996323 BLAKE2B a0c21ec64fd97f011d2e986806b0a47f5f5941f13b7a17fe84f4886a98e91629c641b9e39c2040105ebe4102d8a9c84ebaffbb6a0bf9ef8c48be80804863d441 SHA512 178914d04d1abfaed5fc7e5225e3da54706608d8075298e3b1d7ca4ef09fdef11ee4eb4b7e2f5eb60ab1527b2dcd0c46bbd6b987903be8959ea16e775ca9b548
diff --git a/dev-python/botocore/botocore-1.21.8.ebuild b/dev-python/botocore/botocore-1.21.8.ebuild
new file mode 100644
index 000000000000..30e0988848ad
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}