summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-08-26 14:50:46 +0200
committerSam James <sam@gentoo.org>2022-08-29 23:38:24 +0100
commit8538cf87ad5782d028faca00ddc0ce13073e3bdc (patch)
tree4a2b1dec0a0e0f675711e9f01bb3605521c7440b
parentapp-office/sc-im: new package, add 0.8.2 (diff)
downloadgentoo-8538cf87.tar.gz
gentoo-8538cf87.tar.bz2
gentoo-8538cf87.zip
dev-util/strace: fix live ebuild
It is necessary to call ./bootstrap script before eautoreconf, otherwise automake fails complaining about missing files or directories. The live ebuild is broken since commit a6b222b1be5b, where eautoreconf started to be used even for non-live ebuilds, but it was wrongly placed. Additionally, edo function is used for ./bootstrap call. Fixes: a6b222b1be5b ("dev-util/strace: Fix building with USE="static".") Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/27038 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/strace/strace-9999.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index edcd42346ba7..49ada010927a 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools flag-o-matic toolchain-funcs
+inherit autotools edo flag-o-matic toolchain-funcs
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/strace/strace.git"
@@ -45,16 +45,15 @@ PATCHES=(
src_prepare() {
default
- eautoreconf
-
if [[ ! -e configure ]] ; then
# git generation
sed /autoreconf/d -i bootstrap || die
- ./bootstrap || die
- eautoreconf
+ edo ./bootstrap
[[ ! -e CREDITS ]] && cp CREDITS{.in,}
fi
+ eautoreconf
+
# Stub out the -k test since it's known to be flaky. bug #545812
sed -i '1iexit 77' tests*/strace-k.test || die
}