summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:30:48 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:30:48 +0100
commit856f8100117098436871478e12603bfbc051d2f1 (patch)
tree44b56b342163b4336a2dafcbe8f7fce4957b6ef2
parentdev-python/jupyter_console: Import from science overlay (diff)
downloadgentoo-856f8100.tar.gz
gentoo-856f8100.tar.bz2
gentoo-856f8100.zip
dev-python/pickleshare: Import from science overlay
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-python/pickleshare/Manifest1
-rw-r--r--dev-python/pickleshare/metadata.xml18
-rw-r--r--dev-python/pickleshare/pickleshare-0.5.ebuild34
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pickleshare/Manifest b/dev-python/pickleshare/Manifest
new file mode 100644
index 000000000000..79e862d1c6a4
--- /dev/null
+++ b/dev-python/pickleshare/Manifest
@@ -0,0 +1 @@
+DIST pickleshare-0.5.tar.gz 4441 SHA256 c0be5745035d437dbf55a96f60b7712345b12423f7d0951bd7d8dc2141ca9286 SHA512 1021b76591b5b1d6c777e03c9544fea63602f719b786a2a2e73590f8e8275156fa69b336adf81a6e8abcaad2263eacd76ce4abf2ceff04126ff6b1ffd96cb4e3 WHIRLPOOL 07907feb8dab2dfbfc74e43d17cc076027ab450091a8dd4af197019c6c46e268eda1d5761ab22fc774e37090ab7d51212d82ba284d89018fbc0f52c38f235c62
diff --git a/dev-python/pickleshare/metadata.xml b/dev-python/pickleshare/metadata.xml
new file mode 100644
index 000000000000..ea703f9fdaee
--- /dev/null
+++ b/dev-python/pickleshare/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ Like shelve, a PickleShareDB object acts like a normal dictionary.
+ Unlike shelve, many processes can access the database
+ simultaneously. Changing a value in database is immediately visible
+ to other processes accessing the same database.
+ Concurrency is possible because the values are stored in separate
+ files. Hence the "database" is a directory where all files are
+ governed by PickleShare.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pickleshare</remote-id>
+ <remote-id type="github">pickleshare/pickleshare</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pickleshare/pickleshare-0.5.ebuild b/dev-python/pickleshare/pickleshare-0.5.ebuild
new file mode 100644
index 000000000000..7fd09f4e3d37
--- /dev/null
+++ b/dev-python/pickleshare/pickleshare-0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A small 'shelve' like datastore with concurrency support"
+HOMEPAGE="https://github.com/pickleshare/pickleshare"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/path-py[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# test_pickleshare.py is not included in the pickleshare-0.5 source
+# we fetched from pipy
+RESTRICT="test"
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ cp "${S}"/test_pickleshare.py "${TEST_DIR}"/lib/ || die
+ py.test || die
+}