summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrain0r <hihn.rainer@gmail.com>2019-08-04 14:36:59 +0200
committerMatthew Thode <prometheanfire@gentoo.org>2019-08-10 17:01:00 -0500
commit857a88a8c8054b0de848e093829a622b82a7da2d (patch)
treea151e939c3f1c0976334f1d945155faf17427ed1
parentdev-libs/librdkafka: arm64 stable (bug #691914) (diff)
downloadgentoo-857a88a8.tar.gz
gentoo-857a88a8.tar.bz2
gentoo-857a88a8.zip
- Update to virtualenvwrapper-4.8.4 incl. EAPI 7 - virtualenvwrapper-4.8.2-r1. with EAPI7 and python3_7 - Removed unused use flag - Changed keywords to unstable
Signed-off-by: Rainer Hihn <hihn.rainer@gmail.com> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/virtualenvwrapper/Manifest1
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2-r1.ebuild32
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-4.8.4.ebuild32
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/virtualenvwrapper/Manifest b/dev-python/virtualenvwrapper/Manifest
index 5f6d8c727fd9..7b01680fcc0c 100644
--- a/dev-python/virtualenvwrapper/Manifest
+++ b/dev-python/virtualenvwrapper/Manifest
@@ -1,2 +1,3 @@
DIST virtualenvwrapper-4.7.1.tar.gz 89930 BLAKE2B 8e101f04e365dbb6244bc787f853dd90b15d7b33a44725ac1e047cfa74845b9fe11ca100c8437536d80943f29be1dbe10920eef2ce9766bd95ec05cd96951eba SHA512 f972179992728b8b600388b34562fa9de355f526e4ee25ea88840700a57f196a60eba91ac3137e7d826925c7a8ade7479af383bcbfb8b9b837d0a374b8b3c4fd
DIST virtualenvwrapper-4.8.2.tar.gz 91331 BLAKE2B a01a971ccfdf1822d65fe6d2f3ae09fde2646c8a6246f54316afb6e5d5068078e77732fed3a9805371fefeed7a4357c27b52eed24e9bd03492965779d6a50836 SHA512 53d92f653b988873da5a46e316a40ef767d97f75072e311aa4a8ae45c8aabb49569e36cc35597f9bdfc1f883a51eb648d5f01f4ea8b3237fae30a21dca67d7bc
+DIST virtualenvwrapper-4.8.4.tar.gz 334920 BLAKE2B cd790b1e98cca7d09ea9c80df5d52380335d4a0ea4e6d95f7bd48d78583e0d842e1145ea08d8d8c73516adbe8d6c75bd53c17943723f859860a0cad105a2b058 SHA512 461938100061e11af0ee9b17405d991ae34e5ec9c79cc12614962d3178b588a2da710baa15ac626960b09177c1b5b10c7bc590cb4c126ebd2f719d0f1527c9c4
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2-r1.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2-r1.ebuild
new file mode 100644
index 000000000000..976d371facf7
--- /dev/null
+++ b/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of extensions to Ian Bicking's virtualenv tool"
+HOMEPAGE="https://bitbucket.org/dhellmann/virtualenvwrapper
+ https://pypi.org/project/virtualenvwrapper/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# testsuite doesn't work out of the box. Demand of a virtualenv outstrips setup by the eclass
+RESTRICT=test
+
+RDEPEND="
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/virtualenv-clone[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+
+python_test() {
+ bash ./tests/run_tests || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.4.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.4.ebuild
new file mode 100644
index 000000000000..976d371facf7
--- /dev/null
+++ b/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of extensions to Ian Bicking's virtualenv tool"
+HOMEPAGE="https://bitbucket.org/dhellmann/virtualenvwrapper
+ https://pypi.org/project/virtualenvwrapper/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# testsuite doesn't work out of the box. Demand of a virtualenv outstrips setup by the eclass
+RESTRICT=test
+
+RDEPEND="
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/virtualenv-clone[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+
+python_test() {
+ bash ./tests/run_tests || die "Tests failed under ${EPYTHON}"
+}