summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-08-28 21:37:48 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-08-28 21:38:42 +0200
commit8581fed32888550934a825f8edc52b3a9e8c5b7b (patch)
treeb4d6b3650a74820eed78999d4f3951ef82558d22
parentdev-util/pkgcheck: Add missing test deps (diff)
downloadgentoo-8581fed32888550934a825f8edc52b3a9e8c5b7b.tar.gz
gentoo-8581fed32888550934a825f8edc52b3a9e8c5b7b.tar.bz2
gentoo-8581fed32888550934a825f8edc52b3a9e8c5b7b.zip
sys-apps/qdirstat: bump to version 1.8
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--sys-apps/qdirstat/Manifest1
-rw-r--r--sys-apps/qdirstat/qdirstat-1.8.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/qdirstat/Manifest b/sys-apps/qdirstat/Manifest
index 8a49659058c4..b796c590d8a3 100644
--- a/sys-apps/qdirstat/Manifest
+++ b/sys-apps/qdirstat/Manifest
@@ -1 +1,2 @@
DIST qdirstat-1.7.1.tar.gz 8532003 BLAKE2B 4e3eec17dbfedf602580eb94a8264af40e77e2d5f67d4f0b9bf4a073bcd951ec48b9c3cac50463d0c0a2512a31c69adf10c1f77d6df317c617d4260c7fd845cf SHA512 e272cb603262966f6f24ef0dda268b4c9819783ec43e4f09181f7c6c7c9dac576403b8fc0c3a5b90b85bdc381f491ef3fd0db79ed88993f2bed3157529651ce0
+DIST qdirstat-1.8.tar.gz 8720791 BLAKE2B fd1da935e82c7cdb2880e3a1e2902627c7f3e2972d08ae83a7ca49c4f641c07184c791471fb7a62211660f6e9bfb6fd0dc309c26c0fcffa1cad98de029e2b384 SHA512 fb7b757cf08c6b6ec0c14be9b08b8b6784a36e100c3ac89dbaef176ef908e43c47c2788fc4002a5e5f7308c990518cb3a104166e12cec605ff1a586bd7a4af10
diff --git a/sys-apps/qdirstat/qdirstat-1.8.ebuild b/sys-apps/qdirstat/qdirstat-1.8.ebuild
new file mode 100644
index 000000000000..6943b8116948
--- /dev/null
+++ b/sys-apps/qdirstat/qdirstat-1.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Qt-based directory statistics"
+HOMEPAGE="https://github.com/shundhammer/qdirstat"
+SRC_URI="https://github.com/shundhammer/qdirstat/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+ dev-perl/URI
+"
+
+src_prepare() {
+ default
+
+ # Fix QA warning about incorrect use of doc path
+ sed -e "/doc.path/s/${PN}/${PF}/" -i doc/doc.pro doc/stats/stats.pro || die
+
+ # Don't install compressed man pages
+ sed -e '/gzip/d' -e 's/.gz//g' -i man/man.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}