summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Fan <alex.fan.q@gmail.com>2021-11-28 22:27:17 +1100
committerMarek Szuba <marecki@gentoo.org>2021-11-28 21:28:35 +0100
commit8587dd7a8c040c26cd234baefe517027e4fedc1f (patch)
treeab27e824a21048a50d57baaa98e8658d25490fa9
parentnet-wireless/aircrack-ng: migrate to hwdata (diff)
downloadgentoo-8587dd7a.tar.gz
gentoo-8587dd7a.tar.bz2
gentoo-8587dd7a.zip
sci-libs/superlu_mt: fix int64 not taking effect
upstream uses unconventional variables names. int64 adds _LONG_INT to PREDEFS. PREDEFS seems to be a synonym of CPPFLAGS and used sparingly to be appended to CFLAGS. It should be passed to $(CC) explicitly for int64 to take effect. EXAMLE/Makefile should include ../make.in, which is the same in upstream. Signed-off-by: Alex Fan <alex.fan.q@gmail.com> Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--sci-libs/superlu_mt/files/superlu_mt-3.1-fix-predefs.patch22
-rw-r--r--sci-libs/superlu_mt/superlu_mt-3.1.ebuild3
2 files changed, 23 insertions, 2 deletions
diff --git a/sci-libs/superlu_mt/files/superlu_mt-3.1-fix-predefs.patch b/sci-libs/superlu_mt/files/superlu_mt-3.1-fix-predefs.patch
new file mode 100644
index 000000000000..95c64675a87b
--- /dev/null
+++ b/sci-libs/superlu_mt/files/superlu_mt-3.1-fix-predefs.patch
@@ -0,0 +1,22 @@
+--- a/INSTALL/Makefile
++++ b/INSTALL/Makefile
+@@ -19,7 +19,7 @@ slamch.o: slamch.c ; $(CC) $(NOOPTS) -c $<
+ dlamch.o: dlamch.c ; $(CC) $(NOOPTS) -c $<
+ superlu_timer.o: superlu_timer.c; $(CC) $(NOOPTS) -c $<
+
+-.c.o: ; $(CC) $(CFLAGS) -c $<
++.c.o: ; $(CC) $(PREDEFS) $(CFLAGS) -c $<
+
+ clean:
+ rm -f *.o test* *.out
+--- a/SRC/Makefile
++++ b/SRC/Makefile
+@@ -130,7 +130,7 @@ await.o: await.c
+ $(CC) -c $(NOOPTS) $< $(VERBOSE)
+
+ .c.o:
+- $(CC) $(CFLAGS) $(CDEFS) $(BLASDEF) -c $< $(VERBOSE)
++ $(CC) ${PREDEFS} $(CFLAGS) $(CDEFS) $(BLASDEF) -c $< $(VERBOSE)
+
+ clean:
+ rm -f *.o core ../lib/$(SUPERLULIB)
diff --git a/sci-libs/superlu_mt/superlu_mt-3.1.ebuild b/sci-libs/superlu_mt/superlu_mt-3.1.ebuild
index f631900a16d9..eab8a2ad999d 100644
--- a/sci-libs/superlu_mt/superlu_mt-3.1.ebuild
+++ b/sci-libs/superlu_mt/superlu_mt-3.1.ebuild
@@ -61,8 +61,7 @@ src_prepare() {
TMGLIB=libtmglib.a
EOF
SONAME=lib${PN}.so.${SOVERSION}
- sed -e 's|../make.inc|make.inc|' \
- -e "s|../SRC|${EPREFIX}/usr/include/${PN}|" \
+ sed -e "s|../SRC|${EPREFIX}/usr/include/${PN}|" \
-e '/:.*$(SUPERLULIB)/s|../lib/$(SUPERLULIB)||g' \
-e 's|../lib/$(SUPERLULIB)|-lsuperlu_mt|g' \
-i EXAMPLE/Makefile || die