summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-11 10:50:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-11 12:12:39 +0200
commit8591b592d886d9582286dfd8ce50c2938fae12db (patch)
tree9cc11efb080156ab38079292bd27c0031a83028e
parentx11-themes/papirus-icon-theme: add 20220910 (diff)
downloadgentoo-8591b592.tar.gz
gentoo-8591b592.tar.bz2
gentoo-8591b592.zip
dev-python/sqlalchemy: Bump 1.4.41
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sqlalchemy/Manifest1
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.4.41.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index 11fef09edbfd..de8df970c327 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -1,3 +1,4 @@
DIST SQLAlchemy-1.4.14.tar.gz 7599698 BLAKE2B 500a6257829244e1181b8ef5cb39fb87b62ae2d7ca054fedb580b7431b32d15c8f68600b881eb67eb97a73301660ab96793ab12094ae901782ce4eebdc8929db SHA512 2f33ab034467344ffb19aa3934148faaa4a57e4ffa5f97008d814d54149da4e15cfca14d138b9fb656227e25932ca95cf7321209c31c2706405d3916dc2fb9c0
DIST SQLAlchemy-1.4.39.tar.gz 8212369 BLAKE2B d65993c4342c2cb5bc76ea4ecc986d0ec521a6eb785604ceeca0c9c22187e4af29fc8bd940a130162ca9dd5c30d58b5d0999472285382c6f6bed3863ff9f20cd SHA512 a7c6b73250044289add492b2d7df9010f3b9a3a5126c8b3448d7339cf743c4be3f1c08d238107bb12c579b2bbd7d20e216e331d3ee10dcf79c0f23ca44d496af
DIST SQLAlchemy-1.4.40.tar.gz 8277132 BLAKE2B fa4362a8abec9845beb3cdb65de4066a8a77a40518187a624af3207198395ae3702db5ca5f65970ec7485e8647bdc5a8685f5d9a3b772778c7d6ec66ad820dcf SHA512 49b8ad8becd6fb2c43615890ef05554ce151f44cda20971a585ff5b325a6a91bb356a3c4320f4b1ac877a9eccdca9bec65cc9942bc5948d4143495b5c884f458
+DIST SQLAlchemy-1.4.41.tar.gz 8281227 BLAKE2B 31fb2bfcb41ceefc2c6ed70444b5d8b38a862e06899dd9b5ede7fde0b624ce9f8be766028aaf32b36983268c35e61d87ada5a597260fb97efe72bfc27ce15a71 SHA512 f03a2d4d61a108b4091a4d2ccf2bf49ea22e6c30fcbd70758f89dc3817968e7b5ffa603ce0158812fe42814cd08bbadd00079609a47765d3c534d769835a5543
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.4.41.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.4.41.ebuild
new file mode 100644
index 000000000000..b9b2ea0d21f1
--- /dev/null
+++ b/dev-python/sqlalchemy/sqlalchemy-1.4.41.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1 optfeature
+
+MY_PN="SQLAlchemy"
+MY_P="${MY_PN}-${PV/_beta/b}"
+
+DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
+HOMEPAGE="
+ https://www.sqlalchemy.org/
+ https://pypi.org/project/SQLAlchemy/
+ https://github.com/sqlalchemy/sqlalchemy/
+"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples +sqlite test"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # hardcode call counts specific to Python versions
+ test/aaa_profiling
+)
+
+src_prepare() {
+ sed -i -e '/greenlet/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # warning tests are unreliable
+ test/base/test_warnings.py
+ )
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ test/ext/test_associationproxy.py::ProxyHybridTest::test_msg_fails_on_cls_access
+ )
+ if ! has_version "dev-python/greenlet[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_execution
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_run_sync
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[True-_exclusions0]"
+ "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True-_exclusions0]"
+ )
+ fi
+
+ # upstream's test suite is horribly hacky; it relies on disabling
+ # the warnings plugin and turning warnings into errors; this also
+ # means that any DeprecationWarnings from third-party plugins cause
+ # everything to explode
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=
+ # upstream automagically depends on xdist when it is importable
+ if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
+ PYTEST_PLUGINS+=xdist.plugin
+ fi
+ epytest
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "asyncio support" dev-python/greenlet
+ optfeature "MySQL support" \
+ dev-python/mysqlclient \
+ dev-python/pymysql \
+ dev-python/mysql-connector-python
+ optfeature "postgresql support" dev-python/psycopg:2
+}